Results 1 to 10 of 10

Thread: 1997 Sl900

  1. #1
    www.springbreak-florida.com rgard32's Avatar
    Join Date
    Dec 2006
    Location
    Saint Petersburg,Florida
    Posts
    665

    1997 Sl900

    NO FIRE.......i had originally put an update kit in it...and after awhile of fuking with it....AND adjusting the timing..it ran GREAT for about4 hrs.....now i got zip for fire...

    so far ive checked the stator(ok) coil(ok) AND i pulled the front cover just to see if the timing trigger on the flywheel came off or moved etc..(its ok) also i have put my 1200 cdi in it also..and still nothing.......

    currently its charging(i HOPE that will be it and it works) I will know in a few hrs...

    BUT if that doesnt work..??


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Hope for the battery but have you checked #5 for melting? I know you checked the magnets on the flywheel but the trigger for the ignition is the pickup (#5)


  3. #3
    www.springbreak-florida.com rgard32's Avatar
    Join Date
    Dec 2006
    Location
    Saint Petersburg,Florida
    Posts
    665
    no i just pulled the front cover just to see if 1 of the screws came out lol....IF the battery doesnt work...i guess ill have to pull the flywheel errrr...

  4. #4
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Did you get this fixed?

    Posibility?? http://www.greenhulk.net/forums/show...2&postcount=12

  5. #5
    www.springbreak-florida.com rgard32's Avatar
    Join Date
    Dec 2006
    Location
    Saint Petersburg,Florida
    Posts
    665
    thats an excellent idea...i havent pulled the flywheel yet cause well its a pain LOL..thats an EASY check to do..will do it first thing friday

    THANKS

  6. #6
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    I thought you already checked for minimum 9 volts at the voltage regulator
    Or was that from before?

  7. #7
    www.springbreak-florida.com rgard32's Avatar
    Join Date
    Dec 2006
    Location
    Saint Petersburg,Florida
    Posts
    665
    that was from before.....i did the bilge test...didnt work...so flywheel is comin off err

  8. #8
    www.springbreak-florida.com rgard32's Avatar
    Join Date
    Dec 2006
    Location
    Saint Petersburg,Florida
    Posts
    665
    well i FINALLY got the flywheel off and well its toast...the tiny little allen screws that screw into the flywheel to hold the magnet in place ...2 are gone and the other 2 are almost all the way out..and the magnet spins free inside the flywheel......fluke azz crap lol.

  9. #9
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    At least you figured it out. Don't forget to use locktight on reassembly.

  10. #10
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Guess that's cheaper than a stator.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 sl900 i got in on trade
    By duneriders13 in forum Polaris Projects
    Replies: 8
    Last Post: 06-13-2013, 06:13 AM
  2. FS - Parts Jet pump from 1997 SL900 (stator, impeller, extension ring, tail cone)
    By K447 in forum Polaris Classifieds
    Replies: 4
    Last Post: 04-11-2013, 09:49 PM
  3. 1997 SL900 - Keihin or Bing carbs?
    By K447 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 01-28-2013, 09:35 PM
  4. WTB NEED drive shaft for 1997 SL900
    By john zigler in forum Polaris Classifieds
    Replies: 7
    Last Post: 08-28-2012, 08:13 AM
  5. 1997 sl900 sitting for 2 years?
    By skigolfnut in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-15-2009, 12:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •