Results 1 to 7 of 7
  1. #1
    250 horses and only one jocky
    Join Date
    Feb 2008
    Location
    London Kent
    Posts
    118

    Question Engine faliure??

    Hi all, i had just got my leaking intercooler fixed and all was fine for the next few trips out then yesterday i launched it and started it as usual and went slowly out of the harbour (approx 2mins of riding at 12MPH because of speed limit.) before the whole thing just stops on the spot and it won't re-start, and sounded like the battery was flat or struggling to turn it over, after getting towed in and that night putting my battery on charge i also stripped out the jet pump...nothing was stuck in this and it moved freely. Then i tried turning the drive shaft by hand and couldn't. I then put the re-charged battery back on and tried to crank it over without the spark plugs in...it cranked over but i think slower than usual. Then i put the spark plugs in and tried again.....It sounded like it just fired up fore a nanode second then was struggling to turn again... What do i do now??? I am thinking maybe have a look at the supercharger first but how easy is it to remove this?
    Thanks for your much needed help!


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    it is very easy to remove the sc. there are good instructions in the how to section.

  3. #3
    Robert caldo101's Avatar
    Join Date
    Sep 2007
    Location
    Jacksonville, Fl.
    Posts
    105

    check

    Quote Originally Posted by Daz RXT View Post
    Hi all, i had just got my leaking intercooler fixed and all was fine for the next few trips out then yesterday i launched it and started it as usual and went slowly out of the harbour (approx 2mins of riding at 12MPH because of speed limit.) before the whole thing just stops on the spot and it won't re-start, and sounded like the battery was flat or struggling to turn it over, after getting towed in and that night putting my battery on charge i also stripped out the jet pump...nothing was stuck in this and it moved freely. Then i tried turning the drive shaft by hand and couldn't. I then put the re-charged battery back on and tried to crank it over without the spark plugs in...it cranked over but i think slower than usual. Then i put the spark plugs in and tried again.....It sounded like it just fired up fore a nanode second then was struggling to turn again... What do i do now??? I am thinking maybe have a look at the supercharger first but how easy is it to remove this?
    Thanks for your much needed help!
    ,


    Remove the super charger intake hose and check the impeller, on my RXT the dealer fixed mine due to the ceramic washer, it seems they cut corners and did not rebuild the hole thing and did not replace the bearings therefore they failed the shaft leaned and the impeler locked against the super charger housing tharefore not allowing the engine to start. after that I made sure they intalled a hole new one!!!

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by Daz RXT View Post
    Hi all, i had just got my leaking intercooler fixed
    Did you change the oil after your intercooler leak? The oil would have been full of water.

  5. #5
    250 horses and only one jocky
    Join Date
    Feb 2008
    Location
    London Kent
    Posts
    118
    No because the oil wasn't milky it has reciently been changed, i managed to repair my original intercooler by soldering the leak (only slight one) and then changed the oil filter. i will try looking at the impeller 1st cheers.

  6. #6
    250 horses and only one jocky
    Join Date
    Feb 2008
    Location
    London Kent
    Posts
    118
    Quote Originally Posted by caldo101 View Post
    ,


    Remove the super charger intake hose and check the impeller, on my RXT the dealer fixed mine due to the ceramic washer, it seems they cut corners and did not rebuild the hole thing and did not replace the bearings therefore they failed the shaft leaned and the impeler locked against the super charger housing tharefore not allowing the engine to start. after that I made sure they intalled a hole new one!!!

    Brilliant advice thanks...took my supercharger off today to find the bearing collapsed causing the shaft to lean and impeller up against the housing, this was caused by some numpty fitting the thrust washer the wrong way round! mite have to upgrade to a bigger one now with fuel regulators and intercooler!! Just haven't made up my mind what step to take next ...whether to strip out the engine to check for ball bearings or just to count them and see if any are missing 1st...the plastic cover is in the sump somewhere but this will be stopped by the oil strainers.

  7. #7
    250 horses and only one jocky
    Join Date
    Feb 2008
    Location
    London Kent
    Posts
    118

    Exclamation

    Supercharger rear bearing has collapsed, i have counted all the Ball Bearings and there are 8 so im happy that none have entered the sump because there are 8 in the front end bearing, The only thing that is missing is the bearing cage that holds the balls together...no sign of it? i was wondering if i could possibly use a magnet to fish it out as i really don't want to take the engine out. Should i suck all the oil out and then remove the easy front end oil pump as i am told this is quite easy? What would you do?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ever drop something in a RXP/RXT engine compartment?
    By Pee2xUSee in forum 4-Tec Performance
    Replies: 31
    Last Post: 09-14-2008, 12:16 AM
  2. Engine faliure...
    By 05Limited in forum 4-Tec Performance
    Replies: 58
    Last Post: 03-21-2007, 10:14 AM
  3. How-To: Removing the engine cowling.
    By MikeTrin in forum Sea Doo How To & FAQs
    Replies: 8
    Last Post: 06-23-2005, 10:28 AM
  4. Getting "Check Engine" message on 04 RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-20-2005, 01:15 PM
  5. Gentlemen, do not start your engines...
    By 11 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 06-20-2005, 04:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •