Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032

    RRFPR Observation Question

    Been running my RRFPR for 4-5 hours, set at 60 lbs. This past Sat I was riding for 15-20 minutes steady at 35 just crusing. Then I went to WOT and the ski hesitated several times and it took several times of WOT before it leaned out and ran hard. It was like crusing cause it to 'loaded' up the manifold with fuel that it had to blow/burn it out before it would catch and run hard. I experiencd this several times over the 60 miles we rode. I had not noticed it before now because I was riding harder before and I guess it never had time to load up. I have not been able to check the a/f yet.

    Any suggestions or thoughts. Everything else seemed to be working fine, making 11 lbs boost, no overheating, etc.


  2. #2
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Check your I/C for leaks. It sounds like it may be drinking some water. Remove the Throttle body pipe and look for water inside.

  3. #3
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    Could also be the plugs, had the same symptoms on a gtx-sc.

  4. #4
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by GPRXP Steve View Post
    Check your I/C for leaks. It sounds like it may be drinking some water. Remove the Throttle body pipe and look for water inside.
    Oh, Geez. Good point!!

  5. #5
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by _Lurker_ View Post
    Could also be the plugs, had the same symptoms on a gtx-sc.
    Ok, It's time to replace them...

    Can the fuel 'load up' in the manifold and cause the hesitation I was experiencing or is this just not possible??

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Larry, i seriously doubt it has anything to do with the regulator. Sounds like you need some new plugs.

    If your plugs are really white when you pull them out check for a leaky intercooler

  7. #7
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    larry my ski did this last season and they are right check the plugs and tighten them up, i found moisture on mine

  8. #8

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    O LARRY REMEMBER HOW MY SKI RAN WITH THE LEAKING INNERCOOLER TODD SAYS CALL ME

  9. #9
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    i think we are commencing the start of leaking XS intercoolers... there's already been quite a number of them here and there starting to pop up with core failures

    keep us posted if this is your problem too, or if it was simply new plugs needed

  10. #10
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by Shibby1485 View Post
    i think we are commencing the start of leaking XS intercoolers... there's already been quite a number of them here and there starting to pop up with core failures

    keep us posted if this is your problem too, or if it was simply new plugs needed
    More salt water than fresh?? I searched and really didnt see much on leaking XS's. Maybe I didnt look hard enough.
    Last edited by jtskier11; 03-17-2008 at 11:26 PM.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RRFPR pressure question?
    By Lbaronio in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-10-2012, 07:51 AM
  2. Fuel controller-rrfpr-begi questions?
    By skigolfnut in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-29-2011, 06:49 AM
  3. FZ - MOre Observations & Questions
    By Jack B in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 06-07-2009, 10:34 PM
  4. RRFPR Install questions
    By bruinsrme in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-11-2008, 11:54 AM
  5. RRFPR gauge question
    By bruinsrme in forum 4-Tec Performance
    Replies: 14
    Last Post: 04-29-2008, 07:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •