Results 1 to 5 of 5
  1. #1

    Join Date
    Mar 2008
    Location
    Granbury, Texas
    Posts
    47

    1997 Polaris 1050 MFD

    Does anyone know what componet in the MDF causes the display to come and go or fade in and out?


  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Welcome to the Green Hulk!!!

    Take a look in the tech section. There is some good info in there about this subject.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    I'd guess a loose connection. Make sure the connector is properly seated inside the MFD. Look for loose or corroded wires.

  4. #4

    Join Date
    Mar 2007
    Location
    Nevada
    Posts
    211
    I had same problem with my 98 1050 display you need to find the post that describes the procedure of taking apart the MFD and cleaning a few things it was posted by christian79 can anyone link that thread? I did it and it worked amazing!

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by explude View Post
    I had same problem with my 98 1050 display you need to find the post that describes the procedure of taking apart the MFD and cleaning a few things it was posted by christian79 can anyone link that thread? I did it and it worked amazing!
    Found two threads;

    if you are planning on repairing MFD READ THIS

    How I fixed my MFD

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 Polaris 1050 SL just not running right
    By walimu in forum Polaris PWC Performance
    Replies: 8
    Last Post: 09-02-2016, 02:53 AM
  2. 1997 polaris 1050 sl reving out at 4000 rpm red light flashing
    By frostsnowman in forum Polaris PWC Performance
    Replies: 3
    Last Post: 08-09-2013, 09:45 AM
  3. 1997 polaris 1050 sl reving out
    By frostsnowman in forum Polaris Open Discussion
    Replies: 12
    Last Post: 08-08-2013, 10:18 PM
  4. No spark on a 1997 Polaris 1050 SLTX
    By iowafan66 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-29-2009, 12:04 PM
  5. 1997 Polaris 1050. 120HP(2seater) NEED HELP!
    By hokies222 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-02-2008, 09:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •