Page 1 of 5 123 ... LastLast
Results 1 to 10 of 43
  1. #1
    wavehummer's Avatar
    Join Date
    Jan 2006
    Location
    Phila. PA 19154
    Posts
    594

    I AM PISSED !!!!!

    took my ski out today. last years numbers vs this year 70mph 7900-8000 rpm's...this year 64mph 7000 rpm's...(ski is stock 2005 RXT, and numbers are from gauges).drove for about 45 minutes, ski started to vibrate badly then it slowed down and shut off....could not get it started...checked intake and impellar for blockage..none found..about 30 minutes passed and it turned over but still vibrated, i was a bout 8 miles from dock...ski would only go 18 mph vibrating badly the whole time...about 2 miles from dock it slowed and shut down..i noticed a lot of smoke coming from exhaust..lifted seats, no smoke in engine had to get towed in...checked again for blockage after it was trailer none found and no marks on prop....here's the kicker!! winterized at dealer, they put synthetic oil in...I told them it needs to be regular oil, told be to bring it in to open in the spring and they will change out oil....I did...but did they change oil as they said and is this problem my super charger...I am suppose to take it to OC MD this weekend...looks like that is out...


  2. #2
    wavehummer's Avatar
    Join Date
    Jan 2006
    Location
    Phila. PA 19154
    Posts
    594
    Also, I had no warnings on my panel..only after i got home and put key on did it show a low temp warning

  3. #3
    Wow! When my clutch failed, I didn`t experience vibrations, even though mine only ran a few minutes, I shut it off after seeing no boost.
    I can`t say for sure if when the SC clutches fail would you expeience bad vibrations leading to a slow down and reduced RPM`s, then a shut off. Sounds something is def wrong ...PR...

  4. #4
    wavehummer's Avatar
    Join Date
    Jan 2006
    Location
    Phila. PA 19154
    Posts
    594
    i notice the lower speed and rpms as it was riding normal...i only had it in the water about 45 minutes when it shut down....now it wont even turn over in or out of the water

  5. #5
    I`m assuming you have a warranty!? Looks like the dealer will see it again. sorry to hear that...PR...

  6. #6
    wavehummer's Avatar
    Join Date
    Jan 2006
    Location
    Phila. PA 19154
    Posts
    594
    yes i have an extended warranty too..but i know it wont be fixed for me to take to maryland this weekend..planning this trip for months

  7. #7
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Ormond Beach,fl
    Posts
    1,715
    +1
    28
    I'm with PR....That does NOT sound like a clutch issue(not even close)...sounds more lie a pump/driveline issue......one of the tech gods should chime in anytime now...

  8. #8
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    take the pump off and 100% verify... you gotta be missing something and not seeing a wood chip or something in there.

    but then why would it shut down? low temp, or HIGH temp???

  9. #9
    wavehummer's Avatar
    Join Date
    Jan 2006
    Location
    Phila. PA 19154
    Posts
    594
    i had no warning readouts at all...the vibrations and slow down felt just like it has before when i sucked something up...it always cleared itself by gunning the engine...when i try to start , it sounds like it wants to turn over but it wont...i do think something may be blocked..but all i know how to do is look and feel inside the intake grate and where the water shoots out...don't even know where the pump is located..also, why would it start smoking real bad. i had it running again for a short time, would only do about 18 mph..then shut down all the way and was smoking...smoke stopped after it shut down

  10. #10
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    bc if something is caught in there, the pump is cavitating, losing it's prime and pressure, and not forcing water into the exhaust system to cool it down resulting in some higher than normal exhaust temps and more smoke

    so if it's locked up, pull the pump off. you know where the pump is, ur just not familiar with all the terminology.

    back of the ski, the jet pump an d steering nozzles.... all of 10 nuts and bolts and you have it down to the driveshaft.

    thoroughly inspect... if u see NOTHING... then re-assemble, pull the spark plugs out, and try and crank it see if it turns over.

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. THIS PISSES ME OFF
    By patmcf79 in forum Open Discussion
    Replies: 13
    Last Post: 08-22-2006, 03:33 PM
  2. I am PISSED part two
    By wavehummer in forum Sea Doo Open Discussion
    Replies: 37
    Last Post: 06-26-2006, 04:42 PM
  3. Man my 3yr old is PISSED!
    By sleeplessnMS in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 06-24-2006, 08:53 PM
  4. Good way to piss of the wife!
    By r33pwrd in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-20-2006, 09:01 AM
  5. WHAT HAPPENS WHEN YOU PISS OFF A BLACK WOMAN (VIDEO)
    By ABBOTT in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 03-13-2006, 10:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •