Results 1 to 7 of 7
  1. #1

    Join Date
    Jul 2005
    Location
    Val-d'Or, Quebec, Canada
    Posts
    56

    Smoke and smell after winter

    Hey guys. My 2005 RXP have been winterized by the dealer. I went out yesterday for the first time of the year with my friend, who also have a 2005 RXP. When i was folowing from not so far, i noticed that smell wich seemed like oil burning or something. So i told him, and he told me the same thing about mine. If we pushed it harder, there was some (just a little) blue smoke on both of us. After some time it also all went away, but im just concerned if it is normal.


  2. #2
    Senior Member watermedic's Avatar
    Join Date
    Apr 2005
    Location
    West Virginia
    Posts
    383
    First time starting after winterization it's pretty normal. Check tthe oil level, MOST dealers tend to overfill with oil.

  3. #3
    mink66's Avatar
    Join Date
    Dec 2005
    Location
    Ocean City, MD
    Posts
    62
    If the dealer added a higher than recommended dosage of fuel stabilizer for winterization, then burning that first tank off might give the exhaust a different smell also.

  4. #4

    Join Date
    Jul 2005
    Location
    Val-d'Or, Quebec, Canada
    Posts
    56
    my tank was around half full when i started it. i ran for some time, now its like 1/3 full. should i full the tank with fresh fuel, or should i burn all the old one first?

    i didnt checked the oil. i will check it next time. i had my 10hours maintenance done at the time of winterization, so they may have messed up like they did when i bought it (it was overfilled)

  5. #5
    mink66's Avatar
    Join Date
    Dec 2005
    Location
    Ocean City, MD
    Posts
    62
    If the smell is coming from a high concentration of fuel stabilizer, then it wouldn't hurt to top off the tank. Ideally, you should have filled the tank up all the way anyway as part of the winterzation process then added the correct amount of fuel stabilizer. Filling it up all the way, doesn't allow any chance for condensation to form inside your tank during the winter months.

  6. #6

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    They fog the motor with Sea-Doo lube... If you took it back to the dealer as recommended it would not have happened to you. ( for spring service they run it and then change plugs)

  7. #7

    Join Date
    Jul 2005
    Location
    Val-d'Or, Quebec, Canada
    Posts
    56
    ok... the dealer told me to run it on the hose for a minute or 2 and then i was done...

    anyways, i went back on the lake yesterday and it was fine.... i found out that he overfilled my oil also... as usual... i hate it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 11-13-2012, 09:55 AM
  2. Replies: 12
    Last Post: 07-28-2007, 09:09 AM
  3. First Run After Winter Mods
    By steved in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-01-2007, 11:32 AM
  4. First day out after winter
    By mickey78 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-08-2006, 06:47 PM
  5. Trim not working after winter
    By SpeedStang95 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 05-02-2006, 08:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •