Results 1 to 2 of 2

Thread: 12V LOW!!!

  1. #1
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,009
    +1
    49

    12V LOW!!!

    battery died on me and i was stuck at the beach had to hitch a ride to the store to buy another battery to get home and then it said the same thing, think its my charging system??? Im gona try to get SeaDoo to refund me for that battery i didnt need to get....


  2. #2
    http://www.electricalconnection.com/...icators/bm.htm
    Get the universal model.

    Hook the red wire to the top right fuse (bilge) and the black to the battery.
    It will turn on with the lanyard.
    Turns green then red for a second then back to green. When you pull the lanyard it stays green for about 5-10 seconds then turns off.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	lanyard_703.jpg 
Views:	54 
Size:	61.4 KB 
ID:	3935  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Problem 12V Low!!!
    By greenxd in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-30-2014, 08:23 AM
  2. Rxp 12v low/new battery
    By rxprsn in forum 4-Tec Performance
    Replies: 18
    Last Post: 08-29-2009, 04:32 PM
  3. 155 Speedster 12V LOW
    By strmchzr in forum Sea Doo Sport Boats
    Replies: 13
    Last Post: 06-09-2008, 08:14 AM
  4. 12V LOW alarm
    By H2HO in forum 4-Tec Performance
    Replies: 31
    Last Post: 12-26-2007, 12:13 PM
  5. Display reads 12V LOW
    By 01xdime in forum 4-Tec Performance
    Replies: 7
    Last Post: 02-18-2007, 09:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •