Results 1 to 10 of 10
  1. #1
    PuprleNuprleGPR's Avatar
    Join Date
    Jul 2006
    Location
    Central FL
    Posts
    741

    Steering off-center on bone stock 07...

    The steering is off-center on the brand new 07. Its been like that since I first rode it a few weekends ago, but Ive been busy breaking it in and playing around to look into it lol
    Is this an easy fix with the cable, or something more complicated? The handlebars have to be about 30-40* to the right for the boat to go straight.

    Also, another quick question - I might put my old style J-plate and 1200 grate from the 04 on there and how many more hours would I be able to go before worrying about the tunnel reinf.? (I am right under 10hrs right now, and I understand that gradually letting off the throttle helps save the tunnel)

    Thanks.


  2. #2
    One day at a time..... N8R's Avatar
    Join Date
    Dec 2005
    Location
    TAMPA
    Posts
    3,716
    +1
    41
    i would do it now and save yourself the trouble later. i think there are some kits on the online store available

  3. #3
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    Quote Originally Posted by PuprleNuprleGPR View Post
    The steering is off-center on the brand new 07. Its been like that since I first rode it a few weekends ago, but Ive been busy breaking it in and playing around to look into it lol
    Is this an easy fix with the cable, or something more complicated? The handlebars have to be about 30-40* to the right for the boat to go straight.

    Also, another quick question - I might put my old style J-plate and 1200 grate from the 04 on there and how many more hours would I be able to go before worrying about the tunnel reinf.? (I am right under 10hrs right now, and I understand that gradually letting off the throttle helps save the tunnel)

    Thanks.
    Probably just the cable outta adjustment. Check the front and back of the cable for proper mounting... phucking monkeys at the dealers can never get them cables (trim and steering) in correctly. Also a ride plate not centered can cause it to pull.

    Quote Originally Posted by N8R View Post
    i would do it now and save yourself the trouble later. i think there are some kits on the online store available
    +1 on that

    I have a stock 07 here now with a busted tunnel.

  4. #4
    PuprleNuprleGPR's Avatar
    Join Date
    Jul 2006
    Location
    Central FL
    Posts
    741
    Quote Originally Posted by WFO View Post
    Probably just the cable outta adjustment. Check the front and back of the cable for proper mounting... phucking monkeys at the dealers can never get them cables (trim and steering) in correctly. Also a ride plate not centered can cause it to pull.



    +1 on that

    I have a stock 07 here now with a busted tunnel.
    How many hours?

  5. #5
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    Quote Originally Posted by PuprleNuprleGPR View Post
    How many hours?
    I think a little over 70, but its been like that for a quite while.

  6. #6
    PuprleNuprleGPR's Avatar
    Join Date
    Jul 2006
    Location
    Central FL
    Posts
    741
    mmk...I guess that Ill hold off on the plate and maybe grate until I get the tunnel taken care of, although this thing is even more of a pig outta the hole than my 04

  7. #7
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Check the trim too and make sure neutral is neutral

  8. #8
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    Quote Originally Posted by PuprleNuprleGPR View Post
    mmk...I guess that Ill hold off on the plate and maybe grate until I get the tunnel taken care of, although this thing is even more of a pig outta the hole than my 04
    Seal the shoe while you are at it.

  9. #9
    PuprleNuprleGPR's Avatar
    Join Date
    Jul 2006
    Location
    Central FL
    Posts
    741
    Quote Originally Posted by WFO View Post
    Seal the shoe while you are at it.
    You mean while Im reinforcing the tunnel? I was planning on just sealing the pump, 1200 grate, and plate after the tunnel is sealed. (And maybe free-flow if I can get to 70 with just the hull mods and want extra on the bottom)
    I wont be messing around in the front section under the seat, since thats what kept me front riding my 04 for nearly an year, and why its still apart in the garage lol

    Oh, and would you guys recommend against cutting the slot under right cowling if I jump wakes, play in surf, sub the ski, etc...?

  10. #10
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Quote Originally Posted by PuprleNuprleGPR View Post
    The steering is off-center on the brand new 07. Its been like that since I first rode it a few weekends ago, but Ive been busy breaking it in and playing around to look into it lol
    Is this an easy fix with the cable, or something more complicated? The handlebars have to be about 30-40* to the right for the boat to go straight.

    Also, another quick question - I might put my old style J-plate and 1200 grate from the 04 on there and how many more hours would I be able to go before worrying about the tunnel reinf.? (I am right under 10hrs right now, and I understand that gradually letting off the throttle helps save the tunnel)

    Thanks.
    The reinforcement saves the tunnel, nothing else. Adjusting the steering is simple just get the manual out and look it up pretty self explanatory.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 07-28-2009, 12:30 PM
  2. 07 RXP going 81.6 on a stock ECU
    By mitch411RXP in forum 4-Tec Performance
    Replies: 50
    Last Post: 10-23-2008, 09:02 PM
  3. RXP-X Bone stock top speed on GPS 70.1 mph
    By powertek in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-26-2008, 10:14 AM
  4. Max Speed on a stock 07 RXT?
    By steviey2493 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 08-05-2007, 12:25 AM
  5. Max RPM's on stock '07 RXP/RXT
    By ramnj in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-08-2007, 09:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •