Results 1 to 5 of 5
  1. #1
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11

    03 XPDI Starting problems

    Hey guys, I am having problems with my XP. I push the start button and the starter spins but does not engage. Sometimes it will engage and crank up but not always. Anyways I think I need a new starter. Anyone ever replace one can tell me if it is very complicated? I dont even know where the starter is on the ski. It is kinda cramped around the engine compartment.

    Thanks,
    Ahmed


  2. #2
    diver2694's Avatar
    Join Date
    Feb 2007
    Location
    Milton Keynes U.K.
    Posts
    79
    Are you sure it's the starter motor and not a sticking BENDIX? Starter motor is underneath your carbs'

  3. #3
    It is the starter drive gear, it is located inside the front Magneto cover, a real pain to get apart. The starter drive gear is broke( spring), chipped teeth on drive gear, or you have had water inside the front Magneto cover. The only way to fix it is too pull the exhaust pipe and pull the Magneto cover and check it out.

  4. #4
    diver2694's Avatar
    Join Date
    Feb 2007
    Location
    Milton Keynes U.K.
    Posts
    79
    Or the splines on the strater motor shaft are u/s, if so change both starter motor and bendix.

  5. #5
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Hey guys, the problem ended up being the starter relay. Took it to the dealer and they figured out the problem. That is alot easier to replace then the whole starter or the bendix. Thanks for all your guys help!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 sea doo starting problems
    By tom in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-02-2006, 09:30 PM
  2. 1200xll starting problem
    By hammerdog57 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 06-27-2006, 08:08 PM
  3. 05 RXP Starting problems
    By Cody Townsend in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 05-09-2006, 05:51 PM
  4. '01 Xlt 1200 Hot Start Problem
    By belgianhead in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-09-2006, 11:08 AM
  5. 04 RXP Starting problem/question...
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-01-2005, 10:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •