Results 1 to 7 of 7
  1. #1
    V-Tec, 4-Tech that's how I roll meirvin's Avatar
    Join Date
    Feb 2006
    Location
    Dallas/Ft Worth, Tx
    Posts
    1,514
    +1
    3

    Guess I got a slow one

    Bought a 05 RXP in late Feb broke it in nice only a couple of WOT bursts per outing, 22 hours later and Riva Stage I minus the wedge took it to the river yesterday was windy but water was perfect nice little chop

    about 90 degrees air, water was 84 i got a 67.8 and a 67.3 @ 7800

    Stock I was averaging 65s

    do I need a impeller tweak (solas 14-19R)

    Block offs and sponsons are on the way


  2. #2
    its something w/ prop

  3. #3
    BertInTexas's Avatar
    Join Date
    May 2005
    Location
    Central Texas
    Posts
    377
    I agree,it may very well be that prop.Mine,(when not overfilled with oil) does 8000-8100 rpm's and consistent 66-68 mph stock.Right now it is still overfilled because I have no way currently to extract it,and I am too lazy to take it to the shop and make them do it.I bought a little siphon pump with an aquarium pump size hose,but it won't fit down the damn dipstick tube.Where do you find a hose small enough to fit in there?
    By the way Meirvin,going to PK next weekend,Sunday through Tuesday.

  4. #4
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    meirvin... lots of things to check and do to get it up to speed. make sure ur wear ring is in mint condition... make sure your oil level is perfect, and you need your prop to be repitched if the oil and wear ring are perfect...

    who did the 10 hour service and what was done at it?

  5. #5
    V-Tec, 4-Tech that's how I roll meirvin's Avatar
    Join Date
    Feb 2006
    Location
    Dallas/Ft Worth, Tx
    Posts
    1,514
    +1
    3
    dealer did 10 hour was a little high I got it down to 3/4 between the humps, will take a bit more out I had dealer mechanic do the prop install he said wear ring was good...

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,995
    +1
    1,901
    Send me your prop and let me pitch it. I'll get your RPM's up to 8100 and then you will be flying

    PM me for details.

  7. #7

    Join Date
    Jul 2005
    Location
    Las Vegas, NV
    Posts
    101
    meirvin, I had no trouble whatsoever getting the aquarium hose at Petsmart. Jerry's prop bends are the best..... Terry

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I think I got a slow one.
    By brad2510 in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-15-2012, 05:42 PM
  2. I think I got a slow 250X.
    By SRTOutlaw in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 06-03-2008, 08:37 PM
  3. OK, got a good one
    By ctriverguy in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 03-29-2008, 12:44 PM
  4. I have a really slow one?
    By GODOSIDIS in forum Kawasaki PWC Performance (4-stroke)
    Replies: 42
    Last Post: 10-01-2007, 07:42 AM
  5. Got a new one for all you Hot heads!
    By beachboy66 in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-09-2006, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •