Results 1 to 2 of 2
  1. #1

    1994 Kawasaki 750 xi no spark

    Can anyone help I have a 94 750 xi stock that does not appear to be getting any spark. Replaced battery and it is showing over 12 volts strong. Engine turns over but when I ground a spark plug I see no spark. I check the fuse it is good (only found one). Any help or suggestions is much appreciated.

  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Southeast Ohio
    Try removing the sparkplug boots and trimming a 1/4 inch off the plug wires and replacing the boots.

    Have you tested the coils, cdi, or stator yet?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 Kawasaki 750 st three seater
    By GOAT1616 in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 08-27-2016, 06:34 PM
  2. 1994 Kawasaki 750 ss xi trim fuse
    By spray&Splash2011 in forum Kawasaki Open Discussion
    Replies: 8
    Last Post: 06-09-2011, 05:55 PM
  3. no spark 1994 kawi 750
    By merolamagoo in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-07-2010, 11:21 AM
  4. FS. 1994 Kawasaki 750 SS (or part out ) NY
    By YellowMike in forum Kawasaki Classifieds
    Replies: 11
    Last Post: 08-19-2008, 09:20 PM
  5. 1994 Sl 750 Regulator and spark
    By Playtime in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-16-2007, 12:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts