Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    2001 Genesis Starting Problem

    Anyone know if the Polaris 2002 Manual (19.6MB) listed here http://www.mattmans.com/polaris/upload/

    would work for a 2001 model?

    If not, does anyone know where one is posted out there or where I can purchase one?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Welcome to the Hulk!

    The 2002 manual is probably going to be the same, or close, for most things. Which model 2001 Polaris do you have?

    What problem are you dealing with?

  3. #3
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Quote Originally Posted by Number1HoustonTexansFan View Post
    Anyone know if the Polaris 2002 Manual (19.6MB) listed here http://www.mattmans.com/polaris/upload/

    would work for a 2001 model?

    If not, does anyone know where one is posted out there or where I can purchase one?
    HEY BRIAN(right)
    WELCOME TO THE HULK
    sorry i did not respond to your email --- (i am such a slacker) BUT IT DID MAKE YOU JOIN THE SITE AND TRUST ME THAT IS THE BEST MOVE EVER
    some of the other guys will know better if the 2001 and 2002 are that different...
    again sorry ,,,thanks,,,and enjoy
    mattman

  4. #4
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    As close as F**k is to swearing

  5. #5
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Welcome to the Green Hulk!!

  6. #6

    Starting problem

    I'm not that mechanically inclined so I have to lean on you guys for support. All the Polaris dealers/mechanics in the Houston area refuse to work on Polaris PWCs and specifically the '01 Genesis....they say it's too old.

    So, I'm stuck doing things myself. I'm muddling through it.

    The issue is that the craft set up over the winter (ok..it's Texas...less hot) months and now won't start.

    I've changed the spark plugs...mainly just because they needed it. I've checked the battery and seems fine. I've even used the car battery to charge/jump the Genesis battery.

    When depressing the start button, I get a sound that is something along the lines of .... hhhuTT-ta

    Sorry for the vagueness....anyone help?

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    I imagine the sound is the starter motor turning, or trying to turn.

    Is the sound about the same when you tried boosting with the car battery?
    Note; do NOT have the car engine running when connected to a PWC.

    Look at the drive shaft and coupler to see if it is turning. You might have to remove the plastic cover to get at the drive shaft. Does the engine actually turn over, or is it not moving at all when the starter button is pressed?

    Can you manually rotate the drive shaft at the back of the engine?
    Last edited by K447; 03-29-2008 at 02:29 PM.

  8. #8
    No difference in sound when jumped to a car battery. Don't see drive shaft turning. How would I turn in manually?

  9. #9
    I'm feeling naturally aspirated today pirate33's Avatar
    Join Date
    Aug 2006
    Location
    Lomita, aka Slowmita
    Posts
    1,932
    +1
    7
    Did you jump start it with the car running?(do not do this!!!!!!!!!!)
    is it a carb or injected model?

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by Number1HoustonTexansFan View Post
    No difference in sound when jumped to a car battery.
    Don't see drive shaft turning.
    How would I turn it manually?
    Look into the end of the jet pump (use a flashlight, if needed) while a helper is pressing the starter button. You should be able to see the impeller blades moving (located just ahead of the fixed stator blades), if the engine is turning over.

    Regarding the drive shaft, have a look in the service manual (which you have it downloaded by now - correct?). Page 5.3, exploded diagram.

    The cover is a plastic shroud to keep hands and stuff from getting wrapped around the running drive shaft and shaft coupler (at the bottom rear of the engine). Remove it (presuming someone has not taken it off before you). You should then be able to rotate the drive shaft by hand - you might need to put a wrench on the flats of the coupler.

    If you cannot rotate the engine at all, then perhaps the engine is seized, or the impeller in the pump. If you can rotate the engine by hand, but the starter motor cannot, then the starter motor, the battery, or the wiring is bad.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. genesis starting problem
    By Budman in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-21-2012, 10:44 PM
  2. 2001 gp1200r starting problems
    By Islandrida92 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 01-30-2012, 09:48 AM
  3. 2001 genesis reverse problems
    By muddmadness in forum Polaris Open Discussion
    Replies: 9
    Last Post: 08-05-2009, 10:58 PM
  4. 2001 Genesis power problem - 40 mph @ 5000 rpms
    By Number1HoustonTexansFan in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 08-04-2009, 09:48 AM
  5. Genesis starting problems
    By prairie water in forum Polaris Open Discussion
    Replies: 13
    Last Post: 07-24-2008, 01:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •