Results 1 to 1 of 1
  1. #1

    Join Date
    Mar 2007
    Location
    Jacksonville, NC
    Posts
    12

    2007 FXHO Warning indicator after oil change

    I did an oil change on my 2007 FXHO and right after I started it up on the waterhose the warning indicator immediatly came on beeping and then went to a solid beep (this is a cold motor) I shut off the water and motor checked oil (put in same amount I took out) filter is dry...eventually after stopping the motor and starting the motor it stopped beeping. Is this normal right after an oil change?
    Here is a complete list of events:

    75 degrees
    2007 FXHO
    Turned on ski
    Turned on water
    Ran on waterhose for 15 minutes
    Turned off water
    Turned off ski
    Siphoned oil out
    (About 90 minutes later)
    Replaced oil filter
    Put the same amount of oil in as I took out (measured it)
    Turned on ski (Buzzer sounds warning light on) soon as I turned on the ski (cold engine at this point)
    Turned on water
    Buzzer still sounds and goes solid buzzer
    Turned off water
    Turned off ski
    2-3 minutes later
    Turned on ski and buzzer immediately comes on with warning light
    Turn off ski
    Lock the ski via remote
    Unlock ski via remote
    Start ski
    Buzzer sounds warning light
    Turn off ski
    wait a few minutes
    Turn on ski
    No buzzer no warning light
    Turn on water
    No buzzer no warning light
    ran on water for about 3 minutes
    No Buzzer no warning light
    Oil level is same as before I changed oil
    30 minutes later
    Turned on ski check diagnostics and it is 01 (No warning indicator)

    Could I have dislodged a sensor during the oil change?
    Last edited by jb_turner; 03-28-2008 at 08:13 PM.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 rxt wont idle after oil change "HELP"
    By jfoley in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 09-12-2012, 07:25 PM
  2. Seadoo problem after oil change at the dealerships
    By rxpx2008 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-14-2010, 01:06 PM
  3. 2007 RXP Low RPM after battery change
    By bgates in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-07-2010, 03:20 PM
  4. Higher rpms after oil change, wtf?
    By super_gtx in forum 4-Tec Performance
    Replies: 19
    Last Post: 08-10-2008, 11:37 AM
  5. Displays after Oil Change
    By scgolfer88 in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-16-2007, 05:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •