Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34
  1. #1
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722

    04 RXP issues. Need helpful info.

    Here's the background.

    At the end of last year, I was running a stage 1 04 RXP without any problems at all.

    Since then, I had the ski winterized, Riva SC wheel installed, and oil changed at the dealer. I installed Ext IC, 42# injectors, Flared J-Pipe, Gutted Waterbox, 15/20 Solas, Spark Plugs, Boost Gauge, and thru hull exhaust over the winter.

    Now, I had some issues seating the J-Pipe and there was some smoke coming from it because it was not seated properly. I now have the J-Pipe all seated fine and not smoking, but when I ran the RXP on the hose to make sure everything with the J-Pipe was ok. However, when I ran it on the hose, I think I ran it too long and started to melt my carbon seal.
    The engine had a some smoke coming from inside the hull and the ride plate was really hot. I believe the smoke was coming from the carbon seal, but I may be wrong.

    Today. I dropped the ski in the water and ran it while on the trailer to see if the carbon seal was ok or not. At first there was a tiny bit of smoke at first start up, then it idled fine without any smoke. There was a very light leak coming from the carbon seal. You could see a little bit of water spinning off of it, but no smoke. The smoke in the beginning only lasted a short time. I took the ski out for a quick spin and everything seemed fine. I then took the ski out for a longer ride with the seat on. It seemed to run fine, but I was only runnng at about 7500-7600 RPM when I was at 8050-8100 at the end of last year. I took the ski back, put it on the trailer, pulled the seat and there was smoke again.

    Where is this smoke coming from? Carbon Seal? Or could it be the little bit of water spinning off of the carbon seal hitting the engine and causeing steam.

    I am going to check the oil to see what that is up to. Maybe that is the cause of the RPM loss, but My main concern is the smoke.

    The smoke didn't have any smell to it. I am baffled.


  2. #2
    Quick ? about your setup....you said you're running a Riva Stage TWO wheel right? Why are you running 42# injectors with that setup? Unless I missed something?

  3. #3
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722
    Quote Originally Posted by RXP-REX View Post
    Quick ? about your setup....you said you're running a Riva Stage TWO wheel right? Why are you running 42# injectors with that setup? Unless I missed something?
    I was running lean on the stock injectors.

  4. #4
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Did you check the clampd on the waterbox? Did you check the waterbox itself for pinhole leaks? is the exhaust louder? Do you have a catch can possibly steaming up the engine compartment? I doubt you melted the carbon seal if the boat didn't sink during the ride. was it sprayed with a lube during winterizing? that would heat up and smoke after start up.
    Just tossing ideas out there..

  5. #5
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722
    Did you check the clampd on the waterbox? Clamps are good on the WB.
    Did you check the waterbox itself for pinhole leaks? No. Danny Modded it and assured me he checked it.
    is the exhaust louder? Yes, but not inside the hull, only from the outside.
    Do you have a catch can possibly steaming up the engine compartment? I do have the catch can. Why would this steam?
    I doubt you melted the carbon seal if the boat didn't sink during the ride. I like the sound of that.
    was it sprayed with a lube during winterizing? Yes.
    that would heat up and smoke after start up. But how much would it smoke.
    Just tossing ideas out there.. Thanks for trying to help.

    Tim

  6. #6
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Define the smoke...Is it a light mist, like a quick POOF?...or is it a trail from something? Is it heavy like a cigarette? is it coming from the same spot? if somethign is burning, there should be a slight odor depending on how heavy the smoke is...It could also be vapor mist from the water hitting the hot exhaust pipe...

    If you are down 500rpm, check the oil level first. If the CR was leaking, you'd be cavitating....

  7. #7
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722
    quote=Danny

    Define the smoke...Is it a light mist, like a quick POOF?...or is it a trail from something? Is it heavy like a cigarette?
    Cannot pin point where the smoke is coming from. It isn't whispy like from a cigarette. More like a Fog eminating from the engine compartment.

    If you are down 500rpm, check the oil level first. If the CR was leaking, you'd be cavitating....No Cavitating. Ski was very responsive.


    DOUG - DrewNJ. Help me out here. Maybe you can describe the smoke better. Doug was out with me today.

  8. #8
    Dave Sharp dav_dman's Avatar
    Join Date
    Aug 2005
    Location
    louisville Ky/so. IN
    Posts
    1,453
    +1
    1
    my money is on the waterbox exhaust setup. Pull it apart and put it back together is what i would do.
    or you could buy a bottle of gas leak fluid from home depot natural gas line parts area..you soak the joints and look for bubbles at startup.

  9. #9
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722
    Quote Originally Posted by dav_dman View Post
    my money is on the waterbox exhaust setup. Pull it apart and put it back together is what i would do.
    or you could buy a bottle of gas leak fluid from home depot natural gas line parts area..you soak the joints and look for bubbles at startup.
    I am almost 100% positive its not the exhaust set up. When I had issues seating the J-Pipe, I took everything appart and Cleaned all surfaces. Thems was shiny. Then I put it back together. Ran it on the hose and everything was ok. Then while running on the hose for a couple of minutes the misty, foggy smoke appeared.

  10. #10
    it`s the mechanic

    it sounds alot like the oil burning off the exhaust manifold if the engine was sprayed down for winterization... it will haze the interior for about an hour...

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Buying RXP tomorrow need HELP FAST!
    By transhow in forum 4-Tec Performance
    Replies: 19
    Last Post: 12-31-2008, 10:26 PM
  2. Just bought 04 GXP supercharge..need help
    By guduf4u in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 08-19-2007, 05:54 PM
  3. ultra lx and 250x fuel issues, need help
    By bluebalz in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 07-12-2007, 08:23 AM
  4. 07 RXp I Need Help!!!!!
    By psi_2_high in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-17-2007, 03:48 PM
  5. My 2 RXP's need HELP!
    By Tube Master in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-19-2005, 09:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •