Results 1 to 8 of 8
  1. #1

    Does this look normal?

    While trying to find the cause of water entering my RXP hull I noticed this in the area where the drive shaft enters the RXP. If it is not, any suggestions of what I should do?



  2. #2
    Site Admin MikeTrin's Avatar
    Join Date
    Apr 2005
    Location
    Overland Park, ks
    Posts
    4,186
    +1
    48
    I am not sure what you are trying to point out in the picture. It looks like a normal carbon ring, i don't see any gaps or misalignment.

    Here's what you do, with the ski on the trailer and the nose up, add some water to your bilge up to the drive shaft, but not over it.

    Wait and watch around the intake grate for leaks.

    If you don't see anything then add more water up to and over the drive shaft.

    Give me some more details. I just had a leak in my pump shoe repaired so i may be able to help you.

  3. #3
    Thanks, I will try out your testing method. What I was trying to point out is the exposed shaft area and the black rubber piece that is to the right of it. Is it supposed to be that way or is that rubber piece supposed to some how cover the area to the right of the 2nd from the left clamp? Also I don't know if it helps but I never had any problems with water in the hull till I installed the PPG level 1 kit + Power Pipe + modded water box + OPAS block off plates. I did them all at once so I don't know where I went wrong.

  4. #4
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    Joe, I'm not knowledgeable on that area to know exactly what it's supposed to look like. From memory, that looks normal to me.

    Frank and I had lots of leaks when doing the RR S1. We just got in the habit of backing the ski into the water on the trailer and letting it run for a few minutes with the seat off while we stuck our heads inside. If we started seeing water pooling at the bottom of the hull, we started snooping around until we found the culprit. It seems like a few times it was the coupler leaving the waterbox.

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,962
    +1
    1,889
    looks perfectly normal to me!

  6. #6
    So does anybody know what the purpose of the black rubber piece is?

  7. #7
    Site Admin MikeTrin's Avatar
    Join Date
    Apr 2005
    Location
    Overland Park, ks
    Posts
    4,186
    +1
    48
    The black rubber boot piece helps keep pressure on the carbon ring. The carbon ring keeps water out of the ski. This is what can overheat when you run the ski on the hose on the trailer. Water from the lake cools this seal down.

    The other 1/2 rubber boot is just a protective cover.

  8. #8
    So is that 1/2 rubber boot on the right side where it should be or should it be butting up against the left clamp?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wear ring pictures, does this look normal?
    By NoxImus in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-21-2012, 08:42 PM
  2. does this look normal?
    By rxpwhistler1 in forum 4-Tec Performance
    Replies: 10
    Last Post: 02-01-2008, 06:35 PM
  3. Before and After, Does this look...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 11-03-2006, 08:00 AM
  4. does this look ok...??
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 07-11-2006, 08:20 PM
  5. 05 pump- does this look ok to you?
    By idizzy in forum Yamaha PWC Performance (2-stroke)
    Replies: 25
    Last Post: 12-10-2005, 05:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •