Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 57
  1. #1

    2 hours on the rxt-x and already a problem

    Went out on the water today and within 5 mins started to jump some waves when all of a sudden my supercharger sounded louder then is was before. I started to make my way back in and I gave it trottle to see if I still had full power and it seemed very slugish. Ive been reading about all the problems about the hose popping off the manifold to the water box. You think I have the same problem?


  2. #2
    Student of Speed rxpwhistler1's Avatar
    Join Date
    Nov 2007
    Location
    Oakland County Michigan
    Posts
    708

    hose

    I don't see how that would cause your SC to sound louder, but your exhaust maybe. Sounds like a SC failure of some sort if it suddenly became sluggish (no boost)?

    Take your SC inlet hose off and see if you can turn the SC wheel (fins) by hand with the machine OFF. If it spins freely u have problems

  3. #3

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    Check all your hoses after the SC, that's exactly the symptoms a hose popping off and releasing all your boost. Would be rare that a stock hose does that, but the amount of boost the "X" models are pushing is like no stock ski before it.

  4. #4
    Well for the other riders that it has happened to before, what did you ski do when the hose popped off?

  5. #5
    Quote Originally Posted by gba View Post
    Well for the other riders that it has happened to before, what did you ski do when the hose popped off?
    just like looseing u s/c washers you'll lose all ur boost & a few r's

  6. #6

    Join Date
    Apr 2005
    Location
    Augusta GA
    Posts
    720
    With 2 hours I would not be jumping any waves. The more hours you get the more the ECU will let you get full power. Check all clamps befor you ride, durring and after.

  7. #7

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    It should be very obvious if one of the big air hoses has come off, see if you can find it first. Use a flathead screwdriver the pry off the OEM clamp. You'll need a 3" stainless steel strap-clamp replacement (Home Depot). Clean the place it came off with Windex or alcohol, spray it with a little hairspray, and use a rachet to put the clamp on tight. It will never come loose on its own again.

  8. #8
    ok thanks IM going to check the hoses again, but Ill prolly just drop it off at the dealer to make sure its nothing major, which I dont think it is.

  9. #9
    Quote Originally Posted by gba View Post
    ok thanks IM going to check the hoses again, but Ill prolly just drop it off at the dealer to make sure its nothing major, which I dont think it is.
    becareful how you break it in! they can read the info stored in the ecu...

  10. #10
    I did some WOT runs but never stayed on the trottle long and I only have 2 hours on the ski, so it hasnt even been ran that much

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 05-26-2012, 05:54 AM
  2. 1 hour on the RXPX and it won't start already?!
    By tempest.runner in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-05-2009, 07:52 PM
  3. First 2 hours on the RXT
    By bruinsrme in forum 4-Tec Performance
    Replies: 15
    Last Post: 08-12-2007, 08:48 PM
  4. AWESOME day out on the RXT today, cold water NY :)
    By Shibby1485 in forum 4-Tec Performance
    Replies: 11
    Last Post: 10-02-2005, 06:36 PM
  5. Replies: 17
    Last Post: 05-19-2005, 07:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •