Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    Water Bum Rodneyae's Avatar
    Join Date
    Dec 2006
    Location
    Roanoke, Va
    Posts
    3,083

    Pull those domes off and take a look!!!!

    Well every spring I like to do a compression check and pull the heads off to glance at the piston.... Well I am glad I did. Look at what I found. Looks like I need to rebuild those carbs also!!! Compression was a little low in the mag cyclinder but not alarming. I am glad I pulled the dome to check for piston wash.


    Click image for larger version. 

Name:	100_5192.jpg 
Views:	44 
Size:	621.7 KB 
ID:	65387 Click image for larger version. 

Name:	100_5190.jpg 
Views:	73 
Size:	618.8 KB 
ID:	65388

    Click image for larger version. 

Name:	100_5193.jpg 
Views:	39 
Size:	574.3 KB 
ID:	65389 Click image for larger version. 

Name:	100_5189.jpg 
Views:	35 
Size:	533.8 KB 
ID:	65390


  2. #2
    800AMSOIL4U's Avatar
    Join Date
    Aug 2006
    Location
    Morgan Hill, CA
    Posts
    5,024
    +1
    132
    Bummer. For sure I would go through the carbs. At least you found it now instead of the middle of summer.

  3. #3
    Bing-A-Ding-Ding-Ding, Brrrrrap! Brrrrrrrrrap!!! Polaris_Nut#1's Avatar
    Join Date
    Aug 2006
    Location
    Pittsfield, MA
    Posts
    3,350
    +1
    26
    So how many holes need new pistons?

  4. #4
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Quote Originally Posted by 800AMSOIL4U View Post
    At least you found it now instead of the middle of summer.
    Or even worse...middle of the lake in the middle of summer.

  5. #5
    Water Bum Rodneyae's Avatar
    Join Date
    Dec 2006
    Location
    Roanoke, Va
    Posts
    3,083
    One piston, Wich I got already. I think I can get away with a hone, I will try, and go from there. Glad it did not come apart and take out the bottom end.... It has about 350 hours with no engine work, until now.

  6. #6
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43
    seem like im not the only one that needed a carb rebuild this winter.

  7. #7
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43
    good to catch it now tho

  8. #8

    Join Date
    Feb 2008
    Location
    Florida
    Posts
    82
    Quote Originally Posted by Rodneyae View Post
    It has about 350 hours with no engine work, until now.
    I have to ask whats your secret? What break-in method do you use?

  9. #9

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    he bought that ski used , or did cha have one hell of a last summer rod ?

  10. #10
    800AMSOIL4U's Avatar
    Join Date
    Aug 2006
    Location
    Morgan Hill, CA
    Posts
    5,024
    +1
    132
    Quote Originally Posted by Rodneyae View Post
    One piston, Wich I got already. I think I can get away with a hone, I will try, and go from there. Glad it did not come apart and take out the bottom end.... It has about 350 hours with no engine work, until now.
    And people say that polaris engines do not last. What the hell do they know.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. so pulled my impller off and this is what i found 250x, updated
    By 98gsxl951 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 16
    Last Post: 04-27-2011, 08:10 AM
  2. Gents please take a look and help me out
    By mikegpr03 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 02-20-2008, 11:09 PM
  3. 14 hours, lost 200 rpms, hesitates on take off and bad vibration
    By Chris288 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 08-13-2007, 04:21 PM
  4. RPM and Take off Question
    By meeper in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 06-21-2006, 11:10 PM
  5. Set Button came off and loosing take off speed!
    By Compwhiz82 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-11-2005, 02:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •