Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    May 2007
    Location
    Spain
    Posts
    41

    Intercooler problem

    I have a problem with my riva intercooler on my 15f it keeps breaking becase of the salt water. Does anyone now if their is any intercoler for salt water?


  2. #2
    bacanal32's Avatar
    Join Date
    Aug 2005
    Location
    Puerto Rico
    Posts
    12
    They seem not to be that tough. I bought an IC core slightly bigger and
    had the Riva/Vortech ends welded to it. Will be testing it on Sunday so
    I still don't know how long it will last. It is now set up with water inlet
    on the lower side and the output on top. This way it should not hold
    water and should reduce the rusting.

    Eggy

  3. #3
    dawson's Avatar
    Join Date
    Apr 2007
    Location
    AUSTRALIA
    Posts
    525
    what part is failing on the coolers
    when i first got my riva baot with 45min on it the bottom tank was popped open.

    do you guys flush the cooler after every ride ?

  4. #4

    Join Date
    May 2007
    Location
    Spain
    Posts
    41
    I donīt flush the intercooler after each salt water ride, but i should for what people say specialy with the riva intercooler.

    What other intercoolers are in the market?

  5. #5
    Vortec makes the IC for Riva. Most people use the Vortec. Those things have to be flushed after every Salt ride. You also need to fog the air side of the IC to prevent inside corrosion. Once it starts it goes fast. Use engine fogging oil.

    Also Macc Racing showed me these. Seems as though they may be a great alternitive. Air Barrel

    http://www.pwr-performance.com/intercooler.htm

  6. #6
    Dubz1's Avatar
    Join Date
    Oct 2006
    Location
    Southern California
    Posts
    2,509
    Skip, youve been holding out on us! Good looking IC's...I saw the BOV they had. All the talk of BOV in another thread got me thinking maybe I had an issue. I went to look at it, and its NOT the same BOV that all you guys have. With the aftermarket IC on my ski, i need one like the one at this webiste, OR i would have to get something fabbed up! HUMMMM....200 bucks for a fulley adjustable BOV vs the R&D one..I might look into that one.

  7. #7
    dawson's Avatar
    Join Date
    Apr 2007
    Location
    AUSTRALIA
    Posts
    525
    Quote Originally Posted by Skips313 View Post
    Vortec makes the IC for Riva. Most people use the Vortec. Those things have to be flushed after every Salt ride. You also need to fog the air side of the IC to prevent inside corrosion. Once it starts it goes fast. Use engine fogging oil.

    Also Macc Racing showed me these. Seems as though they may be a great alternitive. Air Barrel

    http://www.pwr-performance.com/intercooler.htm

    PWR is just down the road from me
    my mate uses one on his turbo 15f never had a problem with it.
    they are a bit of a mission to mount and make fit and are pretty heavy too as they hold heaps of water
    but the cooling effecincey would be heaps better than the vortec ones

  8. #8
    bacanal32's Avatar
    Join Date
    Aug 2005
    Location
    Puerto Rico
    Posts
    12
    You need to flush it after every use. I am using this core. http://www.bellintercoolers.com/pages/lacore.html
    So far so good.

    Eggy

  9. #9

    Join Date
    May 2007
    Location
    Spain
    Posts
    41
    Which intercooler would give best preformance a h trim supercharger 20 psi one?

  10. #10
    These intercoolers look sweet!

    dawson, does your buddy ride in the salt?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Intercooler problem
    By smokey in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-26-2012, 02:30 PM
  2. Replies: 12
    Last Post: 10-29-2010, 07:26 PM
  3. oil in intercooler... problem?
    By braaapf7 in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-13-2009, 05:22 PM
  4. Help, stock intercooler removal problems
    By RXP_Noah in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-11-2009, 04:20 PM
  5. gen 2 intercooler install problem
    By skidoo76 in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-07-2009, 08:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •