Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    just GOT TO DO IT! great lakes gpr 1200's Avatar
    Join Date
    May 2006
    Location
    muskegon michigan
    Posts
    798

    ADVENT Problems..

    Has any one other than me got a ADVENT OUT OF THE Box. install correctly, with battery disconected and hook it up with correct polarity? and it does NOTHING?
    I have heard of bad ones but out of the BOX?

    I went to all the work to take my keyway out TOO ... NOT A VERY HAPPY PERSON...


  2. #2
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Quote Originally Posted by great lakes gpr 1200 View Post
    Has any one other than me got a ADVENT OUT OF THE Box. install correctly, with battery disconected and hook it up with correct polarity? and it does NOTHING?
    I have heard of bad ones but out of the BOX?

    I went to all the work to take my keyway out TOO ... NOT A VERY HAPPY PERSON...
    Yes. They don't test them before sending out. I can write a book on all the problems I've had.

  3. #3

    Join Date
    Jan 2006
    Location
    Florida
    Posts
    526
    Quote Originally Posted by Duke View Post
    Yes. They don't test them before sending out. I can write a book on all the problems I've had.
    dament man pres of duke haters club

  4. #4
    philip_gpr's Avatar
    Join Date
    Dec 2005
    Location
    Canada
    Posts
    2,724
    +1
    3
    electronic parts typically work or they don't

    don't sweat it, if it is under warranty Greg will exchange it.

  5. #5
    Yes, they have their problems but Greg stands behind them. Call him and send it back, they will send you a new one. You gonna love it when it's working

  6. #6
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Greg told me they test them before they send them out,ON A REPROGRAMED unit that is.I asked him to test mine and he said they always do before they send them out.Not sure about the new ones though.

  7. #7
    Quote Originally Posted by WATER WOODY View Post
    Greg told me they test them before they send them out,ON A REPROGRAMED unit that is.I asked him to test mine and he said they always do before they send them out.Not sure about the new ones though.
    I don't want to put Greg under the bus but I sent in TCR's for re-programming and it came back not working with a programming error, shit happens.

  8. #8
    just GOT TO DO IT! great lakes gpr 1200's Avatar
    Join Date
    May 2006
    Location
    muskegon michigan
    Posts
    798
    Quote Originally Posted by VOODOO View Post
    You gonna love it when it's working
    I sure want to try it!

    It is alot of work to change a keyway just to have the advent not work.. enough to make me CRY!

    Can some one pm me his direct line?

  9. #9
    Just call the number on the website. The lady will answer, forget her name, she's excellent at getting things handled.

  10. #10
    just GOT TO DO IT! great lakes gpr 1200's Avatar
    Join Date
    May 2006
    Location
    muskegon michigan
    Posts
    798
    COOL! I will.
    Please don't get me WRONG, I Just want a working unit.
    I am sure after hearing from you guys that this will all work out. But I will be sure to let you guys ALL Know one way or the other, Just as I did when My R&D 800 grate cracked.
    R&D stood behind the unit that they sold, and sent me a new one after inspecting it.
    IT WAS HOW THE WAY IT SHOULD BE!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. advent problems
    By whiteelvis in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-06-2010, 11:40 PM
  2. More Advent problems!!!
    By Duke in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 09-01-2007, 12:47 PM
  3. Advent Problems
    By OCFZR in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 05-08-2007, 07:03 AM
  4. Advent problems
    By Duke in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 09-25-2006, 10:39 PM
  5. Advent Problems
    By OCFZR in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-24-2006, 11:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •