Results 1 to 4 of 4
  1. #1
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5

    '95 xp no start issue

    Well i wanted to get the ski out the other day to start up, went to hook up the battery, not even a click, the battery was new last year, What should i look for?

    I notice there is a small black wire coming from the rear electrical box that looks like it goes on the negative post along with the ground, am i right?


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    yep that is a ground. attach it to the negative terminal of the battery post. Did you leave the battery hooked up and in the cold this winter? If yes you are going to need a new battery.The drain is from the MPEM, which is the 15 amp circuit fed from the 15 amp fuse in the black box.

  3. #3
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    I took the battery out over the winter. And just charged it fully

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    open the grey box(MPEM) and the black box and see if you have a blown fuse. Your ski has a DESS post right? Have you tried to start it with the little ground hooked up?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 XP No start and no beep
    By Bhilton2v in forum 2-Stroke Performance
    Replies: 47
    Last Post: 08-03-2010, 06:51 PM
  2. 95 xp no fun to ride
    By svtnos in forum 2-Stroke Performance
    Replies: 12
    Last Post: 06-20-2010, 10:42 PM
  3. 1996 Xp 800 starting issues
    By ianarm77 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-10-2009, 10:49 PM
  4. 1997 polaris sl 700 no start issue
    By yamaha 1100 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 10-21-2008, 11:38 AM
  5. 97 XP No Start
    By tccmi in forum 2-Stroke Performance
    Replies: 6
    Last Post: 09-01-2008, 05:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •