Results 1 to 6 of 6
  1. #1

    Join Date
    Feb 2007
    Location
    naples, fl
    Posts
    61

    Question GTX won't turn off when you pull the key, keeps beeping.

    My 2005 GTX with 30hrs won't turn off when you pull the key, it thinks the key is still on and does the two beeps.
    I can't figure out how to reset it, I tried cleaning the key and the connector, unplugged the battery, nothing changes.

    Has this happened to any of you guys before? Do you guys have any ideas on how to fix it?


  2. #2
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by miguelwhitney View Post
    Has this happened to any of you guys before? Do you guys have any ideas on how to fix it?
    Sorry, I've never heard of this and I don't know how to fix it. May have to replace the dess post. Maybe its shorted out??

  3. #3
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    Yes relpace the Dess post and the problem will go away my rxp did it last year

  4. #4

    Join Date
    Feb 2007
    Location
    naples, fl
    Posts
    61
    I was hoping I didn't need to replace anything...
    Thanks for answering my question, now go out and ride! it's SUNDAY!!!

  5. #5
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    Quote Originally Posted by miguelwhitney View Post
    I was hoping I didn't need to replace anything...
    Thanks for answering my question, now go out and ride! it's SUNDAY!!!
    I would but its snowing

  6. #6
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    tap on or near it with a screwdriver handle, might help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 07-30-2017, 04:15 PM
  2. 1997 zxi 1100 idles fine but cuts off when you squeeze the throttle
    By sws91489 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 9
    Last Post: 07-24-2014, 05:04 PM
  3. 00' Seaoo GTX Info center won't turn off
    By leedanger in forum 2-Stroke Performance
    Replies: 0
    Last Post: 06-20-2012, 10:05 AM
  4. MFD won't turn off
    By Tony in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-07-2007, 03:00 PM
  5. When you pull 2mm of trailing edge on a 15/20?
    By Hecyan in forum 4-Tec Performance
    Replies: 18
    Last Post: 08-14-2006, 04:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •