Results 1 to 5 of 5
  1. #1
    UP UP AND AWAY! GOLD1300R's Avatar
    Join Date
    Mar 2008
    Location
    Sweetwater, TN
    Posts
    18

    Exclamation VIBRATION with throttle

    I have an 07 GP1300R. In the water yesterday I started getting heavy vibration when I applied throttle and I wouldnt really go anywhere. It did it for a bout a inute then stopped and it hasn't done it sense. Is this something I should be woried about? I bout the ski new about 3 weeks ago. Thanks in advance.


  2. #2
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    You had trash in your pump. It worked it's way out. Next time turn off the ski and rock it front/back real hard. Sometimes it works loose... sometimes, you have have to clean it out by hand.

  3. #3
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    Quote Originally Posted by Hydrotoys View Post
    You had trash in your pump. It worked it's way out. Next time turn off the ski and rock it front/back real hard. Sometimes it works loose... sometimes, you have have to clean it out by hand.
    +1

    Also if you are riding and feel the vibration again, turn the engine off and on a few times while in the water. A lot of times that will un-lodge what ever is stuck in there.

  4. #4
    UP UP AND AWAY! GOLD1300R's Avatar
    Join Date
    Mar 2008
    Location
    Sweetwater, TN
    Posts
    18
    Thank for the advice. I kept on turning the ski on and off so I guess that helpedsome. I was worried simply because it is new and I am new to thw watercraft. Thank for the help!

  5. #5
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    No problem, and welcome to the site.

    A visual inspection of your pump tunnel before and after each and every ride should become second nature to you... best 20 seconds of work you'll ever spend.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. excessive vibrations/ no go with throttle
    By tweeder in forum Polaris Open Discussion
    Replies: 14
    Last Post: 07-02-2009, 05:05 PM
  2. Need help with throttle body
    By KamikazeGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 04-23-2008, 04:33 PM
  3. Kawi starts with throttle depressed???
    By Pale Rider in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 09-10-2007, 06:39 PM
  4. Do covers fit with throttle conversion
    By meirvin in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 03-12-2006, 07:44 AM
  5. Does rxp cover still fit with throttle conversion?
    By chitownrxp10 in forum 4-Tec Performance
    Replies: 6
    Last Post: 01-05-2006, 04:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •