Page 1 of 5 123 ... LastLast
Results 1 to 10 of 41
  1. #1

    Join Date
    Apr 2006
    Location
    mn
    Posts
    48

    it wont start (after hard landing)

    i was out on the rxp today and it was real choppy and i was doing a lil jumping and i came kinda hard on one and the ski shut off (itmight have been the cord im not sure) so i try to start it nothing , so i take the seat off i thought maybe it overheated after 10 mins i tryed starting it again nothing. so i swim back to my freinds dock and make sure no wiring came loose or unplugged still nothing. does anyone know what could be the problem? maybe the starter got knocked around? thats what i was htinking. its not the battery because the gauges and everything power up it just wont start.


  2. #2
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    TOPS

  3. #3
    Site Admin MikeTrin's Avatar
    Join Date
    Apr 2005
    Location
    Overland Park, ks
    Posts
    4,186
    +1
    48
    Do you hear any clicking when you try to start it?

  4. #4
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,698
    +1
    20
    Please keep us posted as to what it was when you find it as I like jumping waves also. This never happenned to me but would like to know what you find.

  5. #5

    Join Date
    Apr 2006
    Location
    mn
    Posts
    48
    Quote Originally Posted by miketrin
    Do you hear any clicking when you try to start it?
    yes i did

  6. #6
    Site Admin MikeTrin's Avatar
    Join Date
    Apr 2005
    Location
    Overland Park, ks
    Posts
    4,186
    +1
    48
    I don't think it is the tip over protection switch. it's either a bad cell in the batt or your starter relay went out. I'd pull out the batt and have it tested. It could be something else but I know a lot about the click of death on the rxp and gtx/sc as i've had it happen to both skis 1 week apart. The rxp was a bad relay, the gtx as a bad cell in the batt.

  7. #7

    Join Date
    Apr 2006
    Location
    mn
    Posts
    48
    is the starter relay hard to replace? i really dont want to bring the ski in because that takes forever

  8. #8
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,698
    +1
    20
    Yes a relay sounds like the most plausible option.

  9. #9

    Join Date
    Apr 2006
    Location
    mn
    Posts
    48
    ok so do i order one? or what

  10. #10
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,698
    +1
    20
    I`d test a few things first. Start with the battery then relay, then starter itself. Is your battery dead? If so the pinion gear could be stuck in crank circuit or closed loop.

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Freedom 700 wont start after riding
    By KevinRyan117 in forum Polaris PWC Performance
    Replies: 0
    Last Post: 07-25-2011, 11:16 PM
  2. RXP wont start after winterization.
    By Chaserxp215 in forum 4-Tec Performance
    Replies: 35
    Last Post: 04-18-2010, 04:34 PM
  3. wont start after i shut it off unless jumped
    By yamahamike125 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-19-2009, 06:15 AM
  4. Replies: 13
    Last Post: 08-01-2008, 06:53 PM
  5. Virage 700 bad running after hard landing
    By darrel in forum Polaris Open Discussion
    Replies: 11
    Last Post: 09-04-2007, 12:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •