Results 1 to 4 of 4
  1. #1

    '94 sl 750 sensor hook ups.

    Hi Guys,
    I tried searching the forums. I also tried downloading the manual, but it won't open for me, so I have to ask.
    I have two sensors. I know one of them goes to the water manifold. I think the other is the low oil sensor.
    I can't find where the second sensor hooks up.
    They both have a single brown wire going to them.
    One has a black end and one has a white end. Which one is which, and where does the second one hook in?
    I switched over to premix, so I also have to override the low oil "red" flashing light on the mfd. Any advice on how to take care of this? There is oil in the tank, so the float is up, and it reads 1/2 tank on the mfd. But, I would like to get this red blinking light stopped.
    Thanks for your time.

    Andy (WETBIKER)




  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,573
    +1
    1,272
    Quote Originally Posted by Andy (WETBIKER) View Post
    Hi Guys,
    I tried searching the forums. I also tried downloading the manual, but it won't open for me, so I have to ask.

    I have two sensors. I know one of them goes to the water manifold. I think the other is the low oil sensor.

    I can't find where the second sensor hooks up.

    They both have a single brown wire going to them.
    One has a black end and one has a white end. Which one is which, and where does the second one hook in?

    I switched over to premix, so I also have to override the low oil "red" flashing light on the mfd. Any advice on how to take care of this? There is oil in the tank, so the float is up, and it reads 1/2 tank on the mfd. But, I would like to get this red blinking light stopped.

    Thanks for your time.
    Andy (WETBIKER)
    Welcome to the Hulk!

    If the PDF manual won't open, try downloading it again, AND install the lastest version of Acrobat Reader (ver 8 ). I presume you have downloaded the 1992-1998 beerdart version of the Polaris Service manual.

    I think the Temp sensor wire should be Tan color (light brown), and runs between the sensor and the MFD display, connected through the electrical box.


    The oil level sensor has two wires - Black and Blue. Black should be grounded in the electrical box, and Blu should run on to the MFD. If the MFD is showing 1/2 tank of oil, then the Red warning light shouldn't be warning about oil level.

    The warning light also appears for low fuel, and overheat (Tan wire grounded = overheat).
    Is your fuel tank level low?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Polaris 1992-1998 Warning System operating characteristics (Buzzer, Overheat, RPM limit, etc).jpg 
Views:	89 
Size:	446.2 KB 
ID:	66489  

  3. #3

    Join Date
    Mar 2012
    Location
    Shalimar, Florida, United States
    Posts
    4
    I have a similar situation. Sensor on top of cylinder head cooling pipe has definitely got one brown wire. The on down on the exhaust is definitely tan. My question is do both of these sensors go to the same connector on the electrical box or does the "brown" one go somewhere else? I have a hot light that won't go away.

  4. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Welcome to the Hulk!

    They both go in the same location. You can check for a faulty sensor by removing them one at a time at the circuit board while the hot is blinking. The sensors trigger to a closed position grounding the CDI causing the overheat signal. If you disconnect the one that is bad, the overheat will go away.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 SL 650 water hook up???
    By cwbysfan03 in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 07-20-2015, 10:32 AM
  2. '94 SL 750 Fuel Problem
    By rob2337 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-24-2007, 07:10 PM
  3. 94 SL 750 and 97 SLT780
    By quad2water in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-19-2007, 12:41 AM
  4. 94 SL 750 just purchased what should i check?
    By GameDemon in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-19-2007, 12:01 AM
  5. 94 sl 750 maintenance anyone?
    By ducatifreak152 in forum Polaris PWC Performance
    Replies: 4
    Last Post: 06-09-2007, 03:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •