Results 1 to 8 of 8
  1. #1

    All Parts Installed but a small problem???

    i have installed my new R&D ride plate Island racing mod 4,sealed my pump,reinforced my tunnel,stepped standard sponsons and indstalled 1200 dual bar intake grate.i took my ski out for a test and i could feel the difference .unfortunately no gps so i couldnt see the figures.

    the problem i experinced is the the ski kept popping(porpoising) out the water. my trim tabs are shimmed cause i had this problem before installing parts as well and i was advised on the forum to shim/space the tabs.the lake was sligtly choppy so i dont know weather the water conditions could have been causing this or its a problem with ski.what do u guys suggest


  2. #2
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    You might have to shim the rear of the plate until it rides like you want. Do small adjustments at a time. The Mod 4 I have takes a few shims to make me happy.

  3. #3
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    You mention you had the problem before the plate...Did you make it go away before doing the other mods ?

    May need more washers under the trim tabs.

  4. #4
    after i shimmed the trim tabs before installations it felt much better.

    so now do i shim the rear of the ride plate or shim more on the trim tabs.at the moment i just have 1 washer on each of the 4 bolts on the trim tabs

  5. #5
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Quote Originally Posted by Full_Throttle View Post
    after i shimmed the trim tabs before installations it felt much better.

    so now do i shim the rear of the ride plate or shim more on the trim tabs.at the moment i just have 1 washer on each of the 4 bolts on the trim tabs
    Stock tabs? what do the washers measure?
    Have you measured your plate angle yet?

  6. #6
    @ Water Woody

    the washers used on my trim tabs measure 1.5mm thick with 2cm diameter.

    the ride plate rear measures from the straight edge to ride plate about 24.10mm which should be around around .950

  7. #7

    Join Date
    Jan 2006
    Location
    Texas City, Texas
    Posts
    1,249
    +1
    15
    If I am not mistaken, 1.5mm translates to about 60 thousandths of an inch.

    I do not use trim tabs, but as I understand it a few of the tuners here who use them with their set up put 120-125 thousandths thickness shims on their boats to control porpoising, then adjust their ride plate to maximize speed.

    That sets your trim tabs at about a 2 degree angle by the way.

    Just to give you some perspective on where you are at with your shims.

  8. #8
    African-American
    Join Date
    Feb 2007
    Location
    Cape Town, South Africa
    Posts
    2,226
    +1
    88
    Salty..

    Do they just shim the front of the tabs down ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Extreme build but small problem...
    By Six's and seven's in forum Yamaha Projects & Build Threads
    Replies: 2
    Last Post: 08-24-2013, 10:49 AM
  2. 96 slt 780 new engine installed but problems starting
    By chazman05 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-05-2012, 09:02 PM
  3. Replies: 18
    Last Post: 10-19-2011, 04:35 PM
  4. Replies: 0
    Last Post: 08-05-2010, 07:54 PM
  5. RE Block off installed but.... (problem or ?
    By bruinsrme in forum 4-Tec Performance
    Replies: 17
    Last Post: 10-19-2007, 09:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •