Results 1 to 8 of 8
  1. #1

    got my ski back from the dealer

    I got a 2008 rxt-x with rideplate holes filled, catch can and custom intake grate. My mechanic told me he was trying to fixed instrument cluster because its reading it something wrong. The ski runs awesome, and runs about 8040 rpms. After I get it back the speedo reads over 100mph. Do you think the dealership screwed up the cluster and now they have to reset something?


  2. #2
    sounds like its reading in km/h instead of m/h

  3. #3
    , sounds like it...

  4. #4
    maybe it was ...is there away to change it back or do I have to go back to the dealer again?

  5. #5
    Quote Originally Posted by gba View Post
    maybe it was ...is there away to change it back or do I have to go back to the dealer again?
    unfortunately back to the dealer...
    give them a call after you confirm that it is indeed reading in Kilometers...

  6. #6
    damn....I know for a fact he was screwing around with the instrument cluster so Im almost positive thats why its messed up. THanks for the info

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by gba View Post
    I got a 2008 rxt-x with rideplate holes filled, catch can and custom intake grate. My mechanic told me he was trying to fixed instrument cluster because its reading it something wrong. The ski runs awesome, and runs about 8040 rpms. After I get it back the speedo reads over 100mph. Do you think the dealership screwed up the cluster and now they have to reset something?
    Man, I bet you thought you were flying. LOL
    I am not going to comment on the lovely stealership.

  8. #8
    Alex The Godfather's Avatar
    Join Date
    Jan 2008
    Location
    NC
    Posts
    945
    they did this to mine. the way to tell if it is kilometers (which i will bet you it is) is to check the temp and see if it has a "C" or an "F" next to it... im going to go on the lake and take a pic at like 93 and mess with my friends that dont know bout seados. lol

    im taking mine back and also to fix the hose issue

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Got my boat back from Kerry today!
    By WVGP1200R in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 08-04-2006, 11:04 AM
  2. After I got my pump back from skat I noticed.............
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-03-2006, 12:52 PM
  3. Got my parts today from the FORSTERS
    By RXPNJ in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-01-2006, 10:14 AM
  4. I got my ski back.
    By muskadoo in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-13-2005, 07:28 AM
  5. Got my pump back from Skat Trak today
    By Mark S in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-04-2005, 08:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •