Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    651
    +1
    28

    Question Please Help!! Broken valves...

    Hey Everyone,
    I just purchased R&D Power Valves...Yah I know R&D..
    Which way do I slide the valve in does where it say R&D go on top as I slide it into the slot or down. I will try and attach pic...




    Riva told me it would be obvious when I went to install but it is not..Their is a differance as to which side should go up or down because the valve has a bevel on the shorter side...HELP !!!!!!!!!!!!!!!!!!!


  2. #2
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    R&D goes on top, and faces piston.
    Last edited by Duke; 04-11-2008 at 07:31 AM.

  3. #3

    Join Date
    Jan 2006
    Location
    Taylor, MI 48180
    Posts
    321
    +1
    7
    You better call me asap. We need to talk. Don't start that machine!
    I'm Serious!
    Travis

  4. #4
    Chine Walker
    Join Date
    Nov 2006
    Posts
    598
    Is there a real noticable performance increase with this valve? Since they seem larger, will they affect compression figures?

    jp

  5. #5
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Quote Originally Posted by jpa1300 View Post
    Is there a real noticable performance increase with this valve? Since they seem larger, will they affect compression figures?

    jp
    No performance increase, just more reliability.

  6. #6
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Quote Originally Posted by TCR View Post
    You better call me asap. We need to talk. Don't start that machine!
    I'm Serious!
    Travis
    What's the issue with these Travis? Please share so we all know.

  7. #7
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    r&d faces the piston

  8. #8
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    651
    +1
    28
    Hey TCR,
    I compared these R&D valves to my OEM ones and they were exactly the same size so I installed them. Eberything went smooth. However my servo when done cycling I hear it going ti ti ti ti ti then it stops. Any Ideas?????

  9. #9
    Greenhulk Grasshopah (DRC) HallPass's Avatar
    Join Date
    Jun 2007
    Location
    Kansas
    Posts
    5,587
    +1
    2
    Quote Originally Posted by Ramps View Post
    Hey TCR,
    I compared these R&D valves to my OEM ones and they were exactly the same size so I installed them. Eberything went smooth. However my servo when done cycling I hear it going ti ti ti ti ti then it stops. Any Ideas?????
    well if the sound you are hearing when the ski is off, is what i think it is.. then it is normal. The servo keeps going for a few extra seconds when you turn the ski off.. it like turns them in and out one more time or something like that.. it is normal. Infact it would probably be bad if you didn't hear the servo still moving when your ski first turns off..

  10. #10
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    651
    +1
    28
    He HallPass,
    I hope your build is going well, I try and keep up with the thread. I know the servo motor cycles one more time when I turn the ski off, but after it cycles it goes tick, tick, tick, tick, then it stops. Like it is stuck...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Power Valve issue PLEASE HELP!!
    By ajharbin in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 07-28-2013, 04:41 PM
  2. Please Help with XLT 1200 155HP Power Valve Engine
    By Mark4141 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 06-19-2012, 12:57 PM
  3. please help me ! power exhaust valve very hot on my GTX 787 .
    By hendyho in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-20-2009, 11:46 PM
  4. Broken Throttle Lever.. Please help
    By GT_Rambo in forum Polaris Classifieds
    Replies: 9
    Last Post: 08-03-2008, 09:41 PM
  5. gas valve springs please help
    By joeblo in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 12-09-2006, 02:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •