Results 1 to 5 of 5
  1. #1

    New day...New problem

    My RIVA stage II RXP is continuously getting overheating warnings. The warning stays on until I turn off the ski. At first I thought it was only happening when I ran WOT but then it began happeniong at all different times. All hoses are connected and the intake is clear. Any ideas?


  2. #2
    JAG's Avatar
    Join Date
    Feb 2006
    Location
    Richmond, VA
    Posts
    1,026
    I don't know much, but I'd say it's overheating.

    Sorry... couldn't resist. Hope someone with more knowledge can help you out.

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,443
    +1
    182
    DO NOT RUN IT , unless it's on the trailer!! Your exhaust pipe will melt and the ski will sink. Find the blockage in your cooling system, and flush throughly. Sand in the IC or J pipe passages are common causes. If u cant find it take it to your dealer and they will find the blockage. Remember to run it in 3ft or deeper only.

  4. #4

    Join Date
    Dec 2005
    Location
    tarpon sp. fl.
    Posts
    35
    back flush your i.c.

  5. #5

    Join Date
    May 2005
    Location
    Bristol, WI
    Posts
    121
    Also, make sure the water supply hose to the IC (the one that is connected under the exh. manifold) is not kinked or pinched at all.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. installed skegs today and found new problem
    By daverxp4 in forum 4-Tec Performance
    Replies: 15
    Last Post: 07-13-2007, 04:06 PM
  2. New problem!! Buzzing from electrical box/no start
    By 95SLT750PWC in forum Polaris Open Discussion
    Replies: 10
    Last Post: 06-23-2007, 12:30 AM
  3. Factory service rep see's new problem
    By snapper455 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 06-19-2007, 03:42 AM
  4. Good Grief a New Problem now!!!
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 11-20-2006, 05:22 PM
  5. New Day- New Problem
    By idizzy in forum 4-Tec Performance
    Replies: 22
    Last Post: 07-17-2006, 05:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •