Results 1 to 10 of 10

Thread: Limp Mode

  1. #1

    Join Date
    Jul 2007
    Posts
    25

    Limp Mode

    For some reason my gtx ltd goes into limp mode. First it would do it after about 2hrs, then gradually less and less.. now after about 30 minutes. Then engine goes to 0 rpm for a split second.. doesn't kill. Then my top rpms slowly go down to about 6500 or lower. I had bad gas in the system, but I removed it all. It runs great until the split second of 0 rpm. I hate to bring it to the shop even though it is under warranty b/c they are far away and it will be there for so long.


  2. #2

    Join Date
    Jul 2007
    Posts
    25
    I also noticed that after a 30 second warm up my oil level was about half inch over the top of the bend. Is this ok? Could this be causing the problem?

  3. #3

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by dothedew View Post
    I also noticed that after a 30 second warm up my oil level was about half inch over the top of the bend. Is this ok? Could this be causing the problem?
    to much oil will cause the problem, get it down to below the top bend and see how you get on

  4. #4

    Join Date
    Jul 2007
    Posts
    25
    What do you think the best method for doing this is? It is on a floating dock. Thanks

  5. #5
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by dothedew View Post
    What do you think the best method for doing this is? It is on a floating dock. Thanks
    Did you check the level with the ski in the water, engine warm and idle 30 seconds, then let sit for 30 seconds? Or did you check the level with the ski on the floating dock? If you checked it on the dock, which is not level, you won't get an accurate reading on the dip stick. My ski is on a Jet Dock and I have to put the ski in the water to get a good reading. Once you get a good reading, you can use a vacuum pump for marine engines to vacuum some oil out of the dipstick tube. If you are going to change the oil, insert the tube from the vacuum pump 18.7" down the tube... Ron

  6. #6

    Join Date
    Jul 2007
    Posts
    25
    oh ok duh.. stupid me I was checking on the dock. I'll get an accurate reading and post the results.

  7. #7

    Join Date
    Jul 2007
    Posts
    25
    ok on the water oil level reading shows between 1/4 and 1/2 inch over the top of the bend. Any idea how much oil I should take out? I got a siphon thing so I'll be fukin with that today.

  8. #8

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by dothedew View Post
    ok on the water oil level reading shows between 1/4 and 1/2 inch over the top of the bend. Any idea how much oil I should take out? I got a siphon thing so I'll be fukin with that today.
    you'll probly have to take 1 litre out, if thats to much put some back,

  9. #9

    Join Date
    Jul 2007
    Posts
    25
    ugh.. had a tough time getting even a tiny bit out.. let alone that much.. oh well i'll try again.

  10. #10

    Join Date
    Jul 2007
    Posts
    25
    Ok.. got it about half way on the bend. Ran it @ wot for about 15 minutes, let it sit for about 45 seconds.. checked it again. still half way on the bend. Won't know if the problem is solved until I can ride it for an hour or so.

    took out ~250ml

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Limp mode on a 97 STS.
    By ccassone in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-29-2009, 07:43 AM
  2. limp mode solutions/ suggestions on 95 slx
    By slxcrazy in forum Polaris How To & FAQs
    Replies: 14
    Last Post: 05-06-2007, 10:39 PM
  3. gas level limp mode ?
    By Bone1050 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 03-22-2007, 06:58 PM
  4. limp mode
    By tommy33mac in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 03-21-2007, 09:23 PM
  5. limp mode vs over of fuel
    By andy95'slx780 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 10-02-2006, 04:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •