Results 1 to 3 of 3

Thread: U.M.I question

  1. #1
    thewhitewonder86's Avatar
    Join Date
    Aug 2007
    East Lansing, MI

    U.M.I question

    For those who have installed the umi steering system what did you do with the mode and set buttons since it doesnt use them? Any clever spot to put them so you can still use the info center?

  2. #2
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Long Island, NY
    this is how i did mine... old thread

  3. #3
    outboard john's Avatar
    Join Date
    Jun 2006
    Escondido, Ca.
    Whitewonder. I am finishing up some projects on my 05 RXP and will post pics and some details when I finish. One of which is the install of the U.M.I. steering. There is a bracket in the kit that I don't know what it was intended for. Maybe something on a different model ski. It will mount on the right side of the steering post, just like the dess/lanyard post(left side)but on the right. I used that as a mounting bracket(trimmed, ground and filed to fit the mode buttons) to mount the mode buttons verticaly with the wires facing towards the steering post. I used epoxy to attach the buttons to the bracket. If you do this. Close your hood to check the clearance before glueing. It's a close fit. I'll try and post a pic of just that tomorrow. Good luck.
    Last edited by outboard john; 04-12-2008 at 10:44 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  2. 158 Thermostat question...
    By rx4pain in forum 4-Tec Performance
    Replies: 34
    Last Post: 11-21-2008, 10:36 PM
  3. Oil Level question , this thing mixes me up :(
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-23-2005, 10:03 AM
  4. Question for the Hulk
    By Therock in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-20-2005, 07:13 AM
  5. RXP VTS Question
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts