Results 1 to 10 of 10
  1. #1

    94 SL650 Tuning problem

    Hi there
    I've got a 94 SL650... all compression is good starts fine does not fall on its face on accel...goes to about 3/4 normal rpm then wont gain speed. Kind of spits fuel out the carbs....tried every combination mixture wise with low and high speed adj. Also tried choke etc. Plugs are wet even with minimul high and low speed screws. Running high flow pump.. premix and all the 1 turn of each stuff... Any ideas ???
    Thanks
    Jon
    PS just had the motor out to replace seals and check case. It had this problem before I pulled it.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Welcome to the Hulk!

    Did you check the reeds when you had the engine out?

    Were the carbs cleaned and checked?

    Have you verified that you have good spark on all cylinders?

    Are the plugs all looking the same after running?

  3. #3

    Yes

    New reeds Boysen 2 piece...carbs clean...saw some predetonation / fire in the intakeduring high rev stumbles...Timing???
    Thanks
    Jon

  4. #4

    Forgot

    Spark on all three...very little impact on run when I pull front plug wire. But that plug looks the best. ???

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    I was going to say reeds, but you replaced them.

    Did you go through the carbs thoroughly?

    Might have a bad needle/seat, or the wrong size.

    A bad anti-siphon valve (clear flap on bottom of kidney shaped piece)

    Or with the high volume fuel pump, the restictor may be too small. (too much pressure pushing the needle off the seat)

  6. #6

    K

    Had not thought of that on restrictor.
    I could pull the bronze retrictrer in the am and try it....

    We'll see
    thanks
    jon

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    You don't want to pull the restrictor out, but try a bigger orifice. The restrictor is what gives you fuel psi at WOT.

  8. #8
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,134
    +1
    1,050
    Maybe the restrictor is plugged??

    .

  9. #9

    Getting better

    Thanks for the suggestions. Making progress with a little bit of everything.
    Restrictor is fine got the mixtures alot closer....about one on each carb low and high speed needles.. just need to drop it in the water and see what we got. Thanks alot
    Jon

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    If you don't have any modifications on the ski, why not set the carbs back to stock and work from there? Lots of tuning and jetting onfo in the "tech" section.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Still have the same problem with my 94 SL650
    By RNusbaum in forum Polaris Open Discussion
    Replies: 9
    Last Post: 10-10-2012, 06:51 AM
  2. 94 SL650 The "General" Let the project begin...
    By Rodneyae in forum Polaris Projects
    Replies: 370
    Last Post: 03-29-2011, 10:16 PM
  3. 94 SP starting problem
    By needforspeed04 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-20-2008, 08:00 AM
  4. 94 slt 750 problems
    By ace16a in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-28-2007, 03:45 PM
  5. 94 xp 650cc problems
    By rodschev in forum 2-Stroke Performance
    Replies: 4
    Last Post: 01-04-2007, 05:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •