Results 1 to 9 of 9
  1. #1
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311

    ride plate leaking

    ok I spent most of the afternoon putting my 05 RXT back together, and I had Jim mod my ride plate when I installed the plastic hose fittings I did not use any thread tape I did put a little permatex around the base I did this several days ago so it has dried

    well today after getting it all back together and starting it fotr the first time ( GH box sounds great ) I noticed antifreeze around the base of the plastic pieces has anyone had this happend and is there something I can try as the one under the Riva intercooler is a real pain in the A__ to get to, I have thought about trying to tighten them more but I dont know

    I plan on taking it out this week for a test run as I dont think this will really hurt anything I just cant stand something to leak so anyone have any tips


  2. #2
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Going open loop will fix that problem.

  3. #3
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    Going open loop will fix that problem.
    that was the first thing out of my mouth ( after several 4 letter words )

    I am waiting on Jim`s which I think Dan is testing

    but I would like to get this one fixed until then

  4. #4
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    when you say permatex, assuming you mean silicone, it ain't gonna get better. once it's cured and leaking tightening isn't going to help.

  5. #5
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    If it has the female type fittings there should be a o ring. If it has the male fittings it needs teflon tape around the threads.

  6. #6
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    If it has the female type fittings there should be a o ring. If it has the male fittings it needs teflon tape around the threads.
    I dont know what I was thinking I did not put any tape on the threads I just hope I can get them off and replaced without having to remove the plate

    I am just exicited about testing the plate

  7. #7
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,888
    +1
    499
    My hoses leaked on my RXP from the factory and I asked Jerry about this and he said do away with those factory metal wire clamps and use some regular hose clamps problem solved! Hope this helps Ya!

  8. #8
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    he said do away with those factory metal wire clamps and use some regular hose clamps problem solved! Hope this helps Ya!
    I spent alot of time trying to get those da-n wire clamps back on berfoe I put a regular hose clamp on thise things suc-

  9. #9
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Scott if I was you I would just give up on it and just leave it in the garage .......... . Or I could come work on it for ya..... , get that thing fixed Wedensday looks good....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Drain plug ride plate leak, can I use teflon tape?
    By holdnon72 in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 06-12-2012, 12:03 PM
  2. ride plate leaking??
    By warner0308 in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-31-2012, 01:34 PM
  3. ski fell off trailer now ride plate leaking anti frezze
    By starter99 in forum 4-Tec Performance
    Replies: 15
    Last Post: 03-22-2010, 08:31 AM
  4. RXT Ride plate leaking coolant
    By GarageX in forum 4-Tec Performance
    Replies: 11
    Last Post: 09-13-2009, 11:12 PM
  5. rxpx ride plate leaks
    By jasonze in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-10-2008, 12:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •