Results 1 to 7 of 7

Thread: RRFPR Question

  1. #1
    MPower's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    3,338
    +1
    121

    RRFPR Question

    We installed it and set to 60psi with just the key in. With the motor running it dropped to around 57-58 so we adjusted it so it was on 60psi while running. Now when it is turned off with just the key it reads 66ish but is 60psi once you start it.

    This sound okay?


  2. #2
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    Quote Originally Posted by MPower View Post
    We installed it and set to 60psi with just the key in. With the motor running it dropped to around 57-58 so we adjusted it so it was on 60psi while running. Now when it is turned off with just the key it reads 66ish but is 60psi once you start it.

    This sound okay?

    u set it at 60psi with the engine NOT running because when its running there is VACUM pulling it BELOW the 60 psi setting in the OFF position! your overfueling your ski most likely!

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Set it as per the instructions. 60 psi with engine not running. Its normal for the pressure to drop when you start it.

  4. #4
    MPower's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    3,338
    +1
    121
    So it is okay if it drops to 57-58 PSI once you start it?

  5. #5
    Quote Originally Posted by MPower View Post
    So it is okay if it drops to 57-58 PSI once you start it?
    Yes! That is what mine does, no issues here!

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by MPower View Post
    So it is okay if it drops to 57-58 PSI once you start it?
    Yes, that's exactly what your fuel pressure does even with the stock fuel pressure regulator

  7. #7
    MPower's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    3,338
    +1
    121
    Thanks guys

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT-X Rude RRFPR questions...
    By yz426er in forum 4-Tec Performance
    Replies: 41
    Last Post: 06-19-2009, 10:10 PM
  2. RRFPR question
    By Vern in forum 4-Tec Performance
    Replies: 15
    Last Post: 09-06-2008, 11:52 AM
  3. rrfpr question
    By aviator921 in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-25-2008, 11:42 AM
  4. RRFPR Question
    By Brad Clarke in forum 4-Tec Performance
    Replies: 10
    Last Post: 03-08-2008, 02:58 AM
  5. RRFPR Question
    By Turbo Nick in forum 4-Tec Performance
    Replies: 49
    Last Post: 02-25-2008, 06:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •