Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    Steve STSPERFORMANCE's Avatar
    Join Date
    Dec 2007
    Location
    Cambridge, Ohio
    Posts
    2,701
    +1
    116

    Riva power filter cover UNBELIEVABLY restrictive!!

    Made up a custom 4" air intake for my T-X and covered the end of the tube with Rivas covering for the power filter. Took the ski out and it would not go over 60 mph. Took off the covering and gained an easy 10 mph which is about normal for what I have done to the ski. I now this has been said before but if any of you are still using this as a cover:
    TAKE IT THE FRIG OFF!!!


  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    10 mph ?

    was the filter clean? just asking....

  3. #3
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    Quote Originally Posted by RX951 View Post
    10 mph ?

    was the filter clean? just asking....


    right!, i did many back to back tests and the prefilter had no affect at all. with the 3" riva kit and a 4" intake with the correct 4" filter on it

  4. #4
    10 mph? what were the RPMs before and after......were you running the same impeller? I could see .1 mph or maybe .7 but 10 is outrageous.....you had to of changed something else at the same time.........if I had an X ski running 61-62 mph I would take it back

  5. #5
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722
    +10 MPH. I need to add this to my mod list.

  6. #6
    pet's Avatar
    Join Date
    May 2006
    Location
    Washington DC metro
    Posts
    1,317
    i think he doas not have GPS..... ....just looking at the gade on the ski he may have gained 10mph, just a thought

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by meeper View Post


    right!, i did many back to back tests and the prefilter had no affect at all. with the 3" riva kit and a 4" intake with the correct 4" filter on it
    +1

    I did back to back testing with the pre filter on and off and it made ZERO difference in RPM

  8. #8
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373

  9. #9
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    don't want your prefilter? I'll pay for you to ship it to me!

    sean (seriously)

  10. #10
    I have one that has a hole in it .....it only gave me 8.5 mph tho

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS GP1300R Riva Power Filter with cover 16 hours of use
    By Paul2005GPR in forum Yamaha Classifieds
    Replies: 2
    Last Post: 05-21-2011, 11:24 PM
  2. PPG L 1 Air Intake VS. Riva Power Filter
    By Ultra/RXP in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-07-2005, 01:24 PM
  3. PPG Level 1 Air Intake vs. Riva Power Filter
    By Ultra/RXP in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-07-2005, 05:03 PM
  4. Advantages/Disadvantages to Riva Power Filter Tube
    By Red Devil in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-11-2005, 12:24 PM
  5. Replies: 1
    Last Post: 05-18-2005, 07:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •