Results 1 to 10 of 10
  1. #1
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14

    swap my pump 03, got a question...

    i am swapping in an aluminum pump into my 03 GTX SC,
    took it all apart today. one question.
    i am reusing my stock reduction nozzle and steering nozzle.
    in the reduction nozzle there is a elbow fitting with a screen that fed the OPAS, what should i do with that?
    i am also removing opas.
    take the fitting out and plug hole with what???
    thx


  2. #2
    Quote Originally Posted by lextoy View Post
    i am swapping in an aluminum pump into my 03 GTX SC,
    took it all apart today. one question.
    i am reusing my stock reduction nozzle and steering nozzle.
    in the reduction nozzle there is a elbow fitting with a screen that fed the OPAS, what should i do with that?
    i am also removing opas.
    take the fitting out and plug hole with what???
    thx
    Go to a hardweare store and buy a NPT pipe plug.

  3. #3
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    my new aluminum pump has a plastic plug in it too, what goes there??
    what went there? something for opas also??
    i just leave that plastic plug in correct?
    why did they move the opas water port...

  4. #4
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    lex..

    that's a totally different plug...

    the black plastic plug on the PUMP is not actually a plug... take it out and u'll understand. it has a stem on it with a strainer... that leads to the internal water pressure for the pump that feed the intercooler and exhaust..

    the VENTURI should be plugged tho like RXP6 suggested... 1/2" NPT i believe is the right size? or is it 3/8" NPT ?

  5. #5
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    aha!! yes a different plug altogether. i think the newer opas system eliminated the water pressure diverter altogether??
    so a newer reduction nozzle does not have the NPT port at all??
    i am making my own oPAS regulator blockoff for the top of the pump tunnel out of some pvc

  6. #6
    Doo'n it on the Lake ... GTXDawg's Avatar
    Join Date
    Mar 2008
    Location
    Middle TN
    Posts
    110
    Lextoy - is that an 04 alum housing you're replacing with (part # 267000084)? Where did you find yours? I'm looking for one too!

  7. #7
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    its an 05 GTX SC pump i think, found it here a few months ago, jetskihaven was selling it , he might have more??
    any o4 and up aluminum pump will do, just swap pumps, move your wear ring and impeller into the new housing. or get a 12/20 like i did

  8. #8
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    more questions:
    when i tighten the impeller on should i put on never sieze or what? i plan to test it and then get it tweeked to max rpm's.
    how tight?
    i got a 2 degree wedge, i have siliconed it to the reduction nozzle, keeping the o rings inbetween for a good bailer tube seal. BUT now theres nothing to seal bailer tubes btw the wedge and the pump housing, i want to not put any silicon in this gap so the parts come apart easy.
    what have you all done to seal in the wedges/ bailer tubes? just silicone thos junction also? there is big gaps where o rings could go in the bailer tube channels, should i get some o rings?
    btw the pump and the hull is the rubber seal, and some rubber grommets for the bailer tubes, anything else i need to put in there, silicone? there was nothing before...

  9. #9
    Doo'n it on the Lake ... GTXDawg's Avatar
    Join Date
    Mar 2008
    Location
    Middle TN
    Posts
    110
    Quote Originally Posted by lextoy View Post
    its an 05 GTX SC pump i think, found it here a few months ago, jetskihaven was selling it , he might have more??
    any o4 and up aluminum pump will do, just swap pumps, move your wear ring and impeller into the new housing. or get a 12/20 like i did
    Thanks lextoy - good luck w/ your SC - looks like I'll be following right behind w/ similar projects on mine too.

  10. #10
    NCNismo32's Avatar
    Join Date
    Jan 2007
    Location
    Fayetteville, NC
    Posts
    94
    Quote Originally Posted by lextoy View Post
    more questions:
    when i tighten the impeller on should i put on never sieze or what? i plan to test it and then get it tweeked to max rpm's.
    how tight?
    i got a 2 degree wedge, i have siliconed it to the reduction nozzle, keeping the o rings inbetween for a good bailer tube seal. BUT now theres nothing to seal bailer tubes btw the wedge and the pump housing, i want to not put any silicon in this gap so the parts come apart easy.
    what have you all done to seal in the wedges/ bailer tubes? just silicone thos junction also? there is big gaps where o rings could go in the bailer tube channels, should i get some o rings?
    btw the pump and the hull is the rubber seal, and some rubber grommets for the bailer tubes, anything else i need to put in there, silicone? there was nothing before...
    sheesh!! I thought I could worry about some stuff, when Bill put the 06 RXP pump in mine he didn't silicone the wedge or loctite the impeller to the driveshaft....not totally convinced I got a very good pump though-"Ebay" cause I do hear a rattling noise from the rear of the ski @ speed. I replaced my driveshaft and had SC rebuilt about 2 weeks ago still same noise so kinda worried I might have a bearing bad in the pump or something who knows but other than that been pleased w/ the extended life of my wear rings after the change out. I suggest if you got any concerns about the GTX give him a call or pm him on here username "WMFwatercraft" and he can give you a definitive answer on what to do not to do. Problem I keep having is my bottom bushing/washer/bolt keeps dropping out of the outer nozzle @ speed leaving me w/out steering. This has happened twice in the past year most recently today while riding my 8 yr old stepson...I guess the threads on the venture are shot I dunno anyone else have this problem before?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. doin my carbs got some questions
    By xplayer2885 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 02-18-2008, 07:24 AM
  2. Replies: 2
    Last Post: 09-20-2007, 03:39 PM
  3. Got my pump today!
    By Totallyblown in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 05-25-2006, 09:16 PM
  4. After I got my pump back from skat I noticed.............
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-03-2006, 12:52 PM
  5. Got my pump back from Skat Trak today
    By Mark S in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-04-2005, 08:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •