Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1
    pet's Avatar
    Join Date
    May 2006
    Location
    Washington DC metro
    Posts
    1,317

    carbon ring at 19hrs.........BAD?!

    i hade water coming in even when the ski did not running in the water.
    i tuke the carbon ring off and here it is....look on the picture.
    after 19 hrs ?...why?....it's pretty bad to me,

    by the way i love the tool for removing the C clip....thanks Jerry...just got it tonight and i replaced the ring in 25min.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1241.JPG 
Views:	116 
Size:	1.84 MB 
ID:	68176  


  2. #2
    I would check your engine alignment and remember to try not to spray the carbon ring with lube..........it definately needs to be replaced
    Last edited by cosmic; 04-18-2008 at 09:11 PM. Reason: spelling

  3. #3
    It's bad (very). Engine alignment will help!

  4. #4
    pet's Avatar
    Join Date
    May 2006
    Location
    Washington DC metro
    Posts
    1,317
    Quote Originally Posted by Muddy River View Post
    It's bad (very). Engine alignment will help!
    i know it's bad.....i just don't get it the engine never been out...as far as i know.

  5. #5
    one of the canadians building you RXP could have bee smoking dope when he aligned it........no one is perfect.........

  6. #6
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    hmmmm....you're gonna have to check the engine alignment, it's off somehow. Look into the motor mounts too, one or more could be trashed letting it bounce all over the place.

  7. #7
    pet's Avatar
    Join Date
    May 2006
    Location
    Washington DC metro
    Posts
    1,317
    anybody could help me with the engine alignment ?......near Washington DC, i would travel 150-200 miles ......

  8. #8
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Did you run the ski out of the water for a long period of time? that can get them hot also.

  9. #9
    Quote Originally Posted by GPRXP Steve View Post
    Did you run the ski out of the water for a long period of time? that can get them hot also.
    Just for some reference, what do we consider a long time? I know no more than 30 seconds not on the hose, but on the hose what is considered a long time at idle? Thanks.

  10. #10
    over 5 minutes

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Possible sighs of bad carbon ring or not?
    By dooit260 in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-28-2015, 07:28 AM
  2. Carbon ring failed at 73 hours.
    By saxwinder in forum Sea Doo Open Discussion
    Replies: 39
    Last Post: 10-04-2014, 03:36 AM
  3. 97 XP Full of water!! Bad carbon ring??
    By Inkaddict in forum 2-Stroke Performance
    Replies: 10
    Last Post: 09-07-2007, 09:18 AM
  4. Carbon ring replacement?
    By Rendog in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 01-02-2006, 07:06 PM
  5. Reinforcement of pump tunnel area around carbon ring
    By Green Hulk in forum 4-Tec Performance
    Replies: 12
    Last Post: 08-03-2005, 03:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •