Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11

    Riva Valve Train upgrade question

    Hey everyone, I am in the process of upgrading my valve train and I am to the point where I am re-installing the rocker arm and rockers. I noticed that the arm is not sitting in that little U groove all the way. It is partly out of the groove... lifted up and toward the intake side just a bit. The holes seem to be lining up but they also lined up when i removed the rockers and just sat the rocker arm in the groove. Here are some pictures of the gap and the hole alignment. I did turn the engine via the driveshaft and where I have the cam set is basically the lowest the rocker arm will sit in the grove on the head.

    Anyone can let me know if its ok to just re-install the rockers as they are?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	mini-IMG_0733.JPG 
Views:	37 
Size:	154.3 KB 
ID:	68245   Click image for larger version. 

Name:	mini-IMG_0734.JPG 
Views:	46 
Size:	167.6 KB 
ID:	68246   Click image for larger version. 

Name:	mini-IMG_0735.JPG 
Views:	43 
Size:	185.6 KB 
ID:	68247   Click image for larger version. 

Name:	mini-IMG_0736.JPG 
Views:	32 
Size:	190.5 KB 
ID:	68248   Click image for larger version. 

Name:	mini-IMG_0737.JPG 
Views:	38 
Size:	136.8 KB 
ID:	68249   Click image for larger version. 

Name:	mini-IMG_0738.JPG 
Views:	39 
Size:	182.1 KB 
ID:	68250  



  2. #2
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    More pics

  3. #3
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    ok here are the additional pics
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	mini-IMG_0739.JPG 
Views:	31 
Size:	150.7 KB 
ID:	68251   Click image for larger version. 

Name:	mini-IMG_0740.JPG 
Views:	35 
Size:	100.7 KB 
ID:	68252   Click image for larger version. 

Name:	mini-IMG_0741.JPG 
Views:	30 
Size:	133.4 KB 
ID:	68253  

  4. #4
    HORSEPOWER JUNKIE 9secZO6's Avatar
    Join Date
    Jun 2007
    Location
    Belle Chasse, La.
    Posts
    2,006
    +1
    1

    TDC

    rotate the motor until u line up the marks on the cam sprocket w/ the head (v/c mating surface).....this puts #3 at tdc on the firing stroke and puts all rockers on the cams' base circle (no lift). The rocker shaft will fall right into place Don't forget to use NEW rocker shaft bolts!
    Last edited by Green Hulk; 04-19-2008 at 09:10 AM.

  5. #5
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    I am confused, what marks on the sprocket? Also which piston is #3? The one closest to the rear of the ski?

    Thanks!

  6. #6
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    #3 is the FRONT

    on the camsprocket.... there's 2 marks that say 1503 on them.. they should be parallel with the top of the head..

  7. #7
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    Here is a pic
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	NGK 039.jpg 
Views:	66 
Size:	231.3 KB 
ID:	68280  

  8. #8
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Thanks guys!

  9. #9
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    i just tightened all my bolts down per the riva instructions. i also noticed that the rocker shaft wasnt sitting straight but figured it would flatten out when i tightened the bolts down

  10. #10
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    Would re-using the bolts be the reason why 3 of my threads are stripped? The engine was just re-built so I assume there wasn't much use on them. Now the valve cover has a leak that sprays oil everytime the ski runs. So it's out of commission until I get that fixed.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB: Riva Valve Train Upgrade
    By thompsdw in forum Sea Doo Classifieds
    Replies: 9
    Last Post: 06-19-2009, 09:17 AM
  2. riva valve train upgrade help!
    By vduzin12 in forum 4-Tec Performance
    Replies: 15
    Last Post: 08-16-2008, 06:55 PM
  3. WTB Riva Valve Train Upgrade & UMI
    By kp04rxp in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 04-30-2008, 10:46 PM
  4. Riva valve train upgrade
    By watermedic in forum 4-Tec Performance
    Replies: 1
    Last Post: 03-18-2007, 02:15 AM
  5. Rotax Or Riva Valve Train Upgrade ?
    By RXP04 in forum 4-Tec Performance
    Replies: 13
    Last Post: 02-28-2007, 07:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •