Results 1 to 7 of 7

Thread: 2002 Txi Idle

  1. #1
    polaristxi's Avatar
    Join Date
    Oct 2007
    Location
    Little Elm, TX
    Posts
    52

    Question 2002 Txi Idle

    Took the Txi's out today. Weather was cool and windy, but the ride was worth it. The 2002 still has an idle problem after it gets warm. If the throttle is released, it dies. Will stay running at 2200 rpm, check engine light comes on at 2800, goes away at 3000. Above 3000 rpm it runs but feels like it has a miss.

    Bought this ski last fall from a FL dealer who fought this problem for over a year and than decided to dump the ski. Here's what he did:
    New TPS
    Old EMM sent out twice for checks. No problems found
    New EMM - sent out for checks twice. No problems found.

    I found wrong spark plus installed and the injector wires for the center cylinder crushed under the injector. Also found the flush plug cracked and spraying down the engine. It idles ok for about 10 minutes in the water, than wouldn't run below 2200.

    Is there a way to check the TPS rig without "wrench"? Am going into the reeds over the next few days.

    Open to any and all suggestions. I have the cable and an old Polaris version of "wrench" Haven't tryed it out yet to see if it will work on the 2002.


  2. #2
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    First check compression .Need the actual figures ,don't stick your finger over the plug hole and crank it and say it is enough.Sounds to me as we may be looking at the stator dept anyway but we still need the comp figures .You will need a multi meter and the TXI manual .You can download it from this site .If you can get hold of these we can then go through it with you

    Bernie

  3. #3
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    Quick and easy one to check .Take the TPS junction apart and use a pair of pointy nosed pliers .Crimp the female ends of the connector a little bit so that the contact is firmer .This sounds a little like when the engine vibrates the worst that the TPS contact is fluctuating .lt Costs nothing and does cause problems

    Bernie

  4. #4
    polaristxi's Avatar
    Join Date
    Oct 2007
    Location
    Little Elm, TX
    Posts
    52
    Thanks Bernie. Manual and multi-meter in hand. Had to work today, so will be late tonight before I can get to the pins. Am familiar with stator problem and have pretty good background in electronics on large aircraft. Have checked the grounding/jumper blocks. Everything looks new. Have an extra throttle body with factory set TPS on it. Thinking I might swap it out to see what happens. Know this is going to be something dum.

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    I like airplanes I was a flight line inspector for the T-45 MD11. A wrench for MD11 B1B among others. Who do you work for now??

  6. #6
    polaristxi's Avatar
    Join Date
    Oct 2007
    Location
    Little Elm, TX
    Posts
    52
    United Airlines. Am an inspector on a contract deal for P&W on the F117 engines for the C17's out of Charleston. Spent time on the line at IAD, SFO and IND. Boeings are my game. Lots of water down here. Not many people that know alot about Polaris or fuel injection. Shops won't touch them. They are awsome machines.
    Last edited by polaristxi; 04-20-2008 at 02:33 PM.

  7. #7
    polaristxi's Avatar
    Join Date
    Oct 2007
    Location
    Little Elm, TX
    Posts
    52
    Finally got compression. All 125. Rang out stator and found pins 3 & 10 open. Manual says this is a 45v coil. Have a spare, so will be doing a couple of late nights to it out. Thanks for your help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 F12x Idle problem & Mid Range Problem
    By hondarider in forum Honda Performance
    Replies: 9
    Last Post: 07-07-2010, 10:50 AM
  2. 2002 TXI No MFD wake up
    By dalepatter in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-23-2010, 08:10 AM
  3. 2002 txi
    By sheldonbaker in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-20-2010, 12:40 PM
  4. 2002 TXI won't start and software
    By jcfsr in forum Polaris Open Discussion
    Replies: 2
    Last Post: 10-23-2008, 08:28 AM
  5. 2002 TXI.. Should I Buy
    By ryand in forum Polaris Open Discussion
    Replies: 34
    Last Post: 04-10-2008, 09:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •