Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    jcstinger's Avatar
    Join Date
    Apr 2008
    Location
    brick nj
    Posts
    29

    my 2005 R-12x cavitate since new

    i purchased a 2005 in Sept. of 2007, it was brand new. It has been cavitating since new. Was told by the dealer that I should use the trim lever when excellerating hard, this helped a little, but my two friends just purchased two 2005 in March and they have not had this problem. We have been out together this month on them so I have been able to compare how the three run. Mine cavitates for the first 2 seconds and rpm hit rev limiter. Their skis pop right out of the water without hitting rev limiter. The top speeds of all three skis are the same. Can someone help me with any suggestions of what the problem could be. I want to get fixed before the season starts. Any info would be greatly appreciated!!


  2. #2
    2 things to check, the rear of the intake grate must has sufficient sealant to prevent air leaking into the pump tunnel causing cavitation.
    the other thing to check is impellor to wear ring clearance this must be as close as possible otherwise cavitation will be present.
    replace or rebuild the impellor if the gap is too large.

  3. #3
    jcstinger's Avatar
    Join Date
    Apr 2008
    Location
    brick nj
    Posts
    29
    thanks for the info the clearance looks ok but the back side of the prop has a chip in it also could it be sucking air though the bushing or boot on the out put shaft????? the only way to ck the intake grate is to remove it and reseal right????

  4. #4
    yes i would do it anyway honda only use silicone to seal them, remove it and clean all the areas use a good sealant and reseal it.

  5. #5
    jcstinger's Avatar
    Join Date
    Apr 2008
    Location
    brick nj
    Posts
    29
    i broke down and order a macboost prop and chip. should be here friday if iam going to remove it to inspect it i might as well make it better---faster ---stronger then before ---lof----- any thing to ck on that out put shaft before i put the pump back on f y i oring on pump looks ok
    what stops the water or air from come through the shaft

  6. #6
    supermac's Avatar
    Join Date
    Dec 2005
    Location
    Mooresville, NC
    Posts
    406
    +1
    10
    Hi, Yes I got your order. Most likely you will have it Thursday.

    Dont glue your pump to the support plate. There is an o-ring. Make sure it is not pinched. Do not glue the pump! If you have a cavitation issue, the problem is likely a bad seal from the pump support plate to the hull. The plate is glued on. I would recommend using 3m 5200 silicone adhesive in the gap. Warning, you will never get the plate off if you use this stuff!

  7. #7
    jcstinger's Avatar
    Join Date
    Apr 2008
    Location
    brick nj
    Posts
    29
    cool i hope so i wouild like to take it out sat ---
    oring looks good the seal around the houseing looks ok-- looks hard to unbolt from inside should i reseal any way

  8. #8
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,359
    +1
    973
    Quote Originally Posted by jcstinger View Post
    cool i hope so i wouild like to take it out sat ---
    oring looks good the seal around the houseing looks ok-- looks hard to unbolt from inside should i reseal any way
    If you plan on removing the intake grate/ride plate for further mods at a later date, use any mild silicone sealant. I used a clear automotive type used for windshields and it works good. Also, the bolts holding everything together, including the pump, are aluminum, & need to be torqued to 18 ft. lbs. Apply blue locktight.

  9. #9
    jcstinger's Avatar
    Join Date
    Apr 2008
    Location
    brick nj
    Posts
    29
    should i fill bolt holes with the same sealer?

  10. #10
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,359
    +1
    973
    Quote Originally Posted by jcstinger View Post
    should i fill bolt holes with the same sealer?
    No....use a small bit of rope curled around the bolt head and held in place with 100 mph tape, then cover it up with a small amount of JB weld, sand smooth. Do a search in GH for photos......I think its in the yamaha section or SeaDoo section.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Will a new intake give me more HP on my 2005 RXP
    By bmac in forum 4-Tec Performance
    Replies: 10
    Last Post: 01-15-2012, 10:16 PM
  2. Did he mess up my Vortec s/c wheel too? ...NEW PICS...
    By GeoRXT in forum 4-Tec Performance
    Replies: 52
    Last Post: 06-03-2006, 08:29 AM
  3. Help, having problems with my 2005 RXT, low hours
    By 05rxt in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-10-2006, 11:24 PM
  4. rpm's on a 2005 GTX SC SeaDoo brand new
    By ne14fun in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 10-30-2005, 06:57 PM
  5. Pics of my 2005 RXP on FIRE!
    By WildBill9000 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-31-2005, 03:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •