Results 1 to 4 of 4

Thread: Cavitating?

  1. #1


    I had my 2003 GTX out yesterday, with a new wear ring and the S/C just rebuilt by Jerry to the '06 Specs. By the way, Jerry did a great job and the turn around was amazing. The problem is when I hit the throttle it cavitates really bad. What would be causing this?

  2. #2
    Dr Len's Son MaxMike's Avatar
    Join Date
    Oct 2007
    Barnegat Bay, NJ/ Bergen County, NJ
    you could have left too much or too little space between the wear ring and the rest of the pump

  3. #3
    How do I fix that?

  4. #4

    Join Date
    Sep 2006
    winchester va
    make sure you have the gtx wear ring and not the rxp or rxt the the rxp-t will give you some gap between the prop and wear ring + a 03 or early 04 with the plastic pump will go through a new wear ring in about 10 hrs. thats why i went to the metal pump on my 03 gtx

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Prop boot and cavitation
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 01-28-2011, 08:09 PM
  2. Cavitation help
    By mattpm07 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 05-05-2006, 01:34 PM
  3. R&D Anti Cavitation Cone
    By Kinchyle in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-02-2006, 10:46 AM
  4. Cavitation issue: worried
    By BDNJ in forum 4-Tec Performance
    Replies: 62
    Last Post: 09-13-2005, 08:21 AM
  5. Post on cavitation
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-04-2005, 10:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts