Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672

    RXT w/ mods 1st ride

    Well finally started ski for the first time today..Bought it in January..

    Ran it on the hose for a couple of mins. to check for water leaks, etc with external I/c.. Looked good.

    A little disappointed with RPM's. After 1 hour on clock I pinned it for several seconds. Only got 7700 rpms..
    Then at 2 hours (more like 2. pinned it for a several more seconds.
    Got 7800 rpms/ Hit 70 on dreamo right away and stayed there.
    I slowly pulled away from a friends' Ultra 250 that I know gps's
    at 66+..
    Does anyone think I should have more rpms??
    Will it get better with more hours on it.. Has 3+ after today.

    Holeshot and midrange accelleration are Great! I only have my
    moded 185 hp gtx to compare to.. It does 66+ on gps.

    I can say that: maybe due to intercooler to Throttle body
    air intake not lining up worth a shit.. I will have to cut/ bend
    custom and get 2 22.5 bends from silicone intakes to get
    a better straight shot.. would this by itself cause not getting
    optimal rpm/ power ???
    Water temp: 57*
    Air Temp: 77*
    ended up with 1-2 bars of fuel left after today's ride.
    Buddies on their ultra 250's were on the fuel beeper when I had
    4 bars!!! Of course I was babying it and keeping under 3/4 throttle
    99% of the time..
    Thanks Guys
    Spring will be gone again tomorrow around here.


  2. #2
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    did you start modding the ski before you rode it with zero hours on it

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Wait till your 10 hours are up..The ECU SHOULD open up and you should see your rpms go up..

  4. #4
    Brand spankin new ski?

    I was able to turn 8050-8100 and better on occasion....stock. I didn't keep it there for long....but it did it.

  5. #5
    cbrich's Avatar
    Join Date
    Nov 2006
    Location
    Around Lake Travis
    Posts
    1,374
    +1
    1
    I took my 06 RXT after installing an XS intercooler, I could peg the dream-o-meter at 69 mph at 3/4 throttle. I hoping to get GPS # next weekend, but I was all over the rev limiter at 8,140 RPMs.

  6. #6
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    Yes, Never even started it before all the mods..
    Been a really LONG freakin winter here..
    This board has cost me a fortune!!
    Gotta keep up with the Jone's

    My prop is a "barley used" 14/19 pitched to a 14/18 by Impos.
    I got it from GTXLimited here on board.
    Got the Stage 3 s/c from Skoepp here, was fresh built, then I sent
    it to GH to put in metal washers and check to make sure was perfect.

    Maybe prop just not quite perfect. Just thinking if with
    the BS alignment of I/c to Tb that maybe there is a restriction.
    Or maybe just need to get a few more hours on it.
    Gas is at least 5 mo old (was stabilzed)

    Got that exhaust code too. P1544 after final WOT run.
    That's when I slowly walked the Ultra 250.

  7. #7
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    I had great mid range accell. It seemed like it just quit
    pulling hard after 7000 - 7300 rpms.. Never got near rev limit.

    I just figured I'd hit or be close to 8100 today after 3 hours.
    I'll try to re configure the I'c to TB hose..
    when I put everything together, seems that I'm "pinching down"
    the large rubber exhaust hose where it is between I/C in and outs.

    It did not come loose though, so I dont know why the exhaust code.
    Seemed to get Louder after the warning beep for P1544..

  8. #8
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by Foggy View Post
    Well finally started ski for the first time today..Bought it in January..

    Ran it on the hose for a couple of mins. to check for water leaks, etc with external I/c.. Looked good.

    A little disappointed with RPM's. After 1 hour on clock I pinned it for several seconds. Only got 7700 rpms..
    Then at 2 hours (more like 2. pinned it for a several more seconds.
    Got 7800 rpms/ Hit 70 on dreamo right away and stayed there.
    I slowly pulled away from a friends' Ultra 250 that I know gps's
    at 66+..
    Does anyone think I should have more rpms??
    Will it get better with more hours on it.. Has 3+ after today.

    Holeshot and midrange accelleration are Great! I only have my
    moded 185 hp gtx to compare to.. It does 66+ on gps.

    I can say that: maybe due to intercooler to Throttle body
    air intake not lining up worth a shit.. I will have to cut/ bend
    custom and get 2 22.5 bends from silicone intakes to get
    a better straight shot.. would this by itself cause not getting
    optimal rpm/ power ???
    Water temp: 57*
    Air Temp: 77*
    ended up with 1-2 bars of fuel left after today's ride.
    Buddies on their ultra 250's were on the fuel beeper when I had
    4 bars!!! Of course I was babying it and keeping under 3/4 throttle
    99% of the time..
    Thanks Guys
    Spring will be gone again tomorrow around here.
    Foggy, glad to hear you got on the water. I would bet your ecu will change some with more hours. I have no experience wth the prop setups on the RXT 215's so I really cant help you. You will get it worked out and alot to gain once you get her tuned in. Good Work

  9. #9
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by skoepp View Post
    Foggy, glad to hear you got on the water. I would bet your ecu will change some with more hours. I have no experience wth the prop setups on the RXT 215's so I really cant help you. You will get it worked out and alot to gain once you get her tuned in. Good Work
    Good point on the ECU. Mine was low on RPM's too and I just keep forgetting that more will come with time. I didnt even break an huor today.

  10. #10
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    I hope it gets better Steve.
    That freakin Intercooler was a 2 day project..
    If I wouldnt have already cut and rerouted water hoses,
    I would have done an abort on it..

    Hope rpm and mph pick up as get more hours.

    Just have to figure out the P1544 exhaust overheat issue

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1st gen RXT hull mods
    By 01xdime in forum 4-Tec Performance
    Replies: 0
    Last Post: 09-26-2009, 02:21 AM
  2. 1st ride RXT-X on Lake Havasu
    By iflyems in forum Sea Doo Open Discussion
    Replies: 26
    Last Post: 05-30-2008, 08:07 PM
  3. RXT w/ mods 2nd ride results
    By Foggy in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-05-2008, 12:09 PM
  4. 1st ride w/all the mods
    By maildude in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-02-2007, 07:35 AM
  5. 1st ride with new piston
    By andy95'slx780 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-11-2006, 01:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •