Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Oct 2007
    Location
    Downers Grove & Momence, IL
    Posts
    194

    Charging voltage? 95' XP 720

    What should I see for charging voltage (running voltage) on my 95' XP 720?
    Thanks,
    -=Rick


  2. #2
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Depending on the charge in the battery 12.8 to 14.2.

    Check voltage at battery with ski off,start ski.if you see a increase its charging.

  3. #3

    Join Date
    Oct 2007
    Location
    Downers Grove & Momence, IL
    Posts
    194
    Quote Originally Posted by water worx View Post
    Depending on the charge in the battery 12.8 to 14.2.

    Check voltage at battery with ski off,start ski.if you see a increase its charging.
    Really... This is what I thought.. I need to take a look at my XP, I checked it at some point a while back and it was running under 12 volts, but it didnt seem to be dropping.. I had installed a used stator and flywheel as the motor that was in it when I bought it blew the crank bearings and took them out. I also notice my tach doesnt read right it will jump if I rev it but most the time is stays around 0 rpm... any thoughts?
    -=Rick

  4. #4

    Join Date
    Oct 2007
    Location
    Downers Grove & Momence, IL
    Posts
    194
    BTW The battery light stays out.. the only time it came on is when I ran the battery low from cranking (because I had fogged the engine) and I jumped it off my jumper box, and ran it for 5 minutes or so. Then I pulled the battery and charged it the light has not returned but I never re-checked the charging voltage.
    -=Rick

  5. #5
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    The tach gets its signal from the charging system.

    Sound like you have a charging problem.

  6. #6

    Join Date
    Oct 2007
    Location
    Downers Grove & Momence, IL
    Posts
    194
    Quote Originally Posted by water worx View Post
    The tach gets its signal from the charging system.

    Sound like you have a charging problem.
    What's the quickest way to diagnose it?

  7. #7

    Join Date
    Oct 2007
    Location
    Downers Grove & Momence, IL
    Posts
    194
    Other question is why doesn't the battery light come on then?

  8. #8

    Join Date
    Oct 2007
    Location
    Downers Grove & Momence, IL
    Posts
    194
    One other thing I thought to ask this morning... How long do you think the xp could run for on a fully charged battery assuming its not charging?

  9. #9
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Quote Originally Posted by VetteTech81 View Post
    One other thing I thought to ask this morning... How long do you think the xp could run for on a fully charged battery assuming its not charging?

    The battery in a 720 is only for starting,once its running it runs on its own power,will probally run for a couple of days or more depending on how many times its started.

  10. #10

    Join Date
    Oct 2007
    Location
    Downers Grove & Momence, IL
    Posts
    194
    Quote Originally Posted by water worx View Post
    The battery in a 720 is only for starting,once its running it runs on its own power,will probally run for a couple of days or more depending on how many times its started.
    Thanks good to know, I was wondering if this was the case since it was a magneto setup. I'm heading down to georgia to visit my mom and sister who is home from the IRAQ (She is a black hawk piolit) and I wanted to take my GTI and XP out and this was a concern from last season.

    Thanks for your help. How does the Tach work off the charging system exactly? I thought it was driven off the ignition signal?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 xp 720 motor mounts
    By turbo1000 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 09-01-2008, 08:58 PM
  2. 95 xp 720 high compression?
    By amdeus in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-06-2008, 08:04 PM
  3. WANTED, 95 xp 720 mpem
    By cntryby in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 05-07-2008, 01:55 PM
  4. 95' Xp 720 charging question
    By VetteTech81 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 12-31-2007, 10:00 AM
  5. Just picked up a 95 xp (720)
    By ADAMBOMB in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-29-2007, 09:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •