Results 1 to 6 of 6
  1. #1

    Join Date
    Jan 2007
    Location
    Milwaukee, Wisconsin, United States
    Posts
    773
    +1
    1

    Help with UMI '05+ GPR

    Can UMI be used on my 2005 gpr ? Do i have to do anything different with the off throttle stuff please let me know.

    Kevin


  2. #2
    My son (mohawk man) jeffsntx's Avatar
    Join Date
    Sep 2006
    Location
    Belton TX
    Posts
    2,598
    +1
    1
    Just leave the off throttle steering unhooked.

  3. #3
    SpeedJunky's Avatar
    Join Date
    Dec 2005
    Location
    Michigan
    Posts
    1,118
    +1
    35
    Just put the UMI on my 05 and relocated the off steering inside the hull bolted to the underside of the steering area.
    The system appears to be a inductive transducer and sends a voltage output. You cannot just disconnect it, it will give you a error code.

    Some pics of what I did.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Picture 1016.jpg 
Views:	58 
Size:	624.0 KB 
ID:	68861   Click image for larger version. 

Name:	Picture 1019.jpg 
Views:	43 
Size:	542.3 KB 
ID:	68862  

  4. #4
    My son (mohawk man) jeffsntx's Avatar
    Join Date
    Sep 2006
    Location
    Belton TX
    Posts
    2,598
    +1
    1
    Quote Originally Posted by SpeedJunky View Post
    Just put the UMI on my 05 and relocated the off steering inside the hull bolted to the underside of the steering area.
    The system appears to be a inductive transducer and sends a voltage output. You cannot just disconnect it, it will give you a error code.

    Some pics of what I did.


    I forgot that the later models are different. The earlier models with the different sensors on them could just be disconnected if Im not mistaken. Sorry for the confusion.

  5. #5
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by SpeedJunky View Post
    Just put the UMI on my 05 and relocated the off steering inside the hull bolted to the underside of the steering area.
    The system appears to be a inductive transducer and sends a voltage output. You cannot just disconnect it, it will give you a error code.

    Some pics of what I did.

  6. #6
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Quote Originally Posted by SpeedJunky View Post
    Just put the UMI on my 05 and relocated the off steering inside the hull bolted to the underside of the steering area.
    The system appears to be a inductive transducer and sends a voltage output. You cannot just disconnect it, it will give you a error code.

    Some pics of what I did.
    smart idea !

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Looking for help with a 05 RXP
    By bulldog in forum 4-Tec Performance
    Replies: 21
    Last Post: 09-29-2011, 03:11 PM
  2. Need help with tripple pipe GPR
    By rxpblast in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-02-2011, 08:44 PM
  3. Need help with UMI system!
    By shavedupsdime in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-03-2010, 05:39 PM
  4. Need Help with painting my GPR
    By Water4fire in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 01-23-2009, 10:01 PM
  5. HELP with umi handlebars set up
    By COUJAR in forum Yamaha PWC Performance (2-stroke)
    Replies: 24
    Last Post: 08-16-2008, 11:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •