Results 1 to 7 of 7
  1. #1
    WaterScooter's Avatar
    Join Date
    Jul 2007
    Location
    Tally, Florida
    Posts
    125

    rubber bushing on prop shaft

    noticed that this black rubber bushing has some tear in it..what is this part? wondering how important this is?..should this part be covered for warranty?..hope the pics help
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00333.JPG 
Views:	54 
Size:	146.9 KB 
ID:	68887   Click image for larger version. 

Name:	DSC00334.JPG 
Views:	53 
Size:	98.8 KB 
ID:	68888   Click image for larger version. 

Name:	DSC00335.JPG 
Views:	51 
Size:	102.5 KB 
ID:	68889  


  2. #2
    If I remember correctly I think itís not needed and some of us remove it during the installation of a new impeller. The gurus can chime in and correct me if Iím wrong.

  3. #3
    O ya to replace that rubber seal require you to remove the ride plate and pump assembly, not a hard job to do but you will have to seal the ride plate again. As for being covered under warranty, it might be but I'm sure your dealer would not want to do it for such a small thing I would guess itís about 2 hours of labor for a 5.99 seal.

  4. #4
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,445
    +1
    650
    I have run with out mine for close to 100 hours, even back in the day we run the Ultra 150's with out them........Have you noticed any cavitation?

  5. #5
    WaterScooter's Avatar
    Join Date
    Jul 2007
    Location
    Tally, Florida
    Posts
    125
    no cavitation..just wondering if it's something i need to fix or wait for it to fall off..what exactly does this part do anyway?

  6. #6
    Clear the air space! MKaman's Avatar
    Join Date
    Jul 2007
    Location
    Feasterville, PA
    Posts
    1,531
    That's funny, mine was the same way when I pulled my pump from one of my 07's
    I thought I did it when I pulled the pump.....maybe not

    Dave at Impros replaced it when he did my pump work.
    Last edited by MKaman; 04-22-2008 at 07:38 PM.

  7. #7
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,445
    +1
    650
    its a bushing for the shaft into the impeller,im sure it does something, but I have never had an issue with out it..................

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help! Impeller shaft stuck on prop!
    By zixxerluv in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 06-16-2011, 04:33 PM
  2. Rubber Dampers on shaft for SLs
    By Frozen in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-17-2010, 10:24 PM
  3. Pushing the Prop Nose Cone over Rubber Bushing?
    By thompsdw in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 02-17-2008, 03:31 PM
  4. Rubber nose cone on prop
    By fussy1 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 11-25-2007, 12:31 AM
  5. Stuck prop on the shaft again
    By Lvnspeed in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 11-24-2007, 09:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •