Results 1 to 3 of 3

Thread: Is this normal?

  1. #1
    WildBill9000's Avatar
    Join Date
    May 2005
    Location
    Pittsburgh, PA
    Posts
    195

    Is this normal?

    shoud the prop shaft boot be running out that bad?
    Attached Files Attached Files


  2. #2
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    I think that is a little excessive. THe main thing, does it leak?

    Tilt the ski as far back as you can, put that intake tube back on and fill the ski with water just over the seal. Run it on the hose for 5 minutes and see if you see any water dripping from the intake grate where the drive shaft enters the hull. You may have to get under the ski while it is running to check.

    I don't have the time to remove everything to take a good video, but here is a quick one of mine.
    Attached Files Attached Files

  3. #3
    WildBill9000's Avatar
    Join Date
    May 2005
    Location
    Pittsburgh, PA
    Posts
    195
    no it doesnt leak. not yet anyways.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New RXP-X - Few questions - Is this normal?
    By boostaholic in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-29-2008, 11:01 AM
  2. Is this normal???
    By Full_Throttle in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 03-11-2008, 12:57 AM
  3. is this normal?
    By 07vette in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-04-2007, 12:08 AM
  4. Is this normal?!?!
    By Titanese in forum 4-Tec Performance
    Replies: 21
    Last Post: 06-30-2007, 07:43 AM
  5. Is this normal???? Plug not connected....?
    By GeoRXT in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-29-2006, 09:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •