Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    first mod's omg this is crazy

    k i have a 04 rxp riva thru hull and riva air intake and intake grate was surprised to see a 2mph loss but omg it gets to top speed a hell of alot faster it was also kinda weird with the opas off that was hard to get use to at first i didnt like it was to loose but after awile got use to it and now i love it i was wondering i was only getting 7700 rpm does that sound right and what should i do to get the 2mph back oh yea i filled the ride plate holes also.


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by soldierpage View Post
    k i have a 04 rxp riva thru hull and riva air intake and intake grate was surprised to see a 2mph loss but omg it gets to top speed a hell of alot faster it was also kinda weird with the opas off that was hard to get use to at first i didnt like it was to loose but after awile got use to it and now i love it i was wondering i was only getting 7700 rpm does that sound right and what should i do to get the 2mph back oh yea i filled the ride plate holes also.

    Repitch it to get back to 8100 and you'll getyour speed back...

    Plus, are you going off a GPS?

  3. #3
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    Ya should not have lost rpm's or speed w/ the mods... Ya have another problem mr.

  4. #4
    no gps but i was consist with 70 on speedo before today never got over 67

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by soldierpage View Post
    no gps but i was consist with 70 on speedo before today never got over 67
    something isn't right. What were your RPM's before you did any mods?

  6. #6
    actually about 7800 i believe but not real sure it doesnt feel slower at all wonder if the speedo just actin crazy

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    You really need to get a GPS. You can't rely on the dreamometer.

    You are down 400 RPM's which is costing you 3+ mph

    Find your missing RPMs!

    The usual cause is
    worn wear ring
    over filled oil
    boost leak

  8. #8

    Join Date
    Jun 2006
    Location
    Richmond, Va
    Posts
    240
    I'm surprised to see a 400 RPM losso just by installing the intake and grate. Not much that can go wrong with those two simple upgrades. Maybe a boost leak like Jerry mentioned.

  9. #9
    where do i put in the coupon code in the store?

  10. #10
    SoFlaRiders Member mksmi's Avatar
    Join Date
    Jul 2007
    Location
    Tamarac,FL (south Florida)
    Posts
    622
    Quote Originally Posted by rxp-x78410 View Post
    where do i put in the coupon code in the store?
    Durning check out there will be a box for it.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. OMG..this is crazy...new 300..
    By Emol:TX in forum 4-Tec Performance
    Replies: 26
    Last Post: 11-23-2016, 08:13 AM
  2. okay this is crazy
    By stingray152003 in forum Videos & Pictures
    Replies: 0
    Last Post: 02-26-2008, 04:24 PM
  3. LOL This is Crazy!
    By branix in forum Videos & Pictures
    Replies: 6
    Last Post: 10-05-2007, 02:56 PM
  4. First mods...How does this sound?
    By HH_Ed in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-23-2007, 03:57 PM
  5. OMG...this is Awesome
    By Totallyblown in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-25-2006, 11:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •