Results 1 to 6 of 6
  1. #1

    vts gauge notworking plz help

    help me. my vts gauge is not working nor is my speedo first my vets tho eaverything n the vts workes but the gauge is saying its all the way up all the time and then my speedo isnt working and i carnt figure out why i looked at all the fuses and sheked them on a maulty meater and they ar all alright plz help me


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Welcome!

    If the gauge goes all the way up then it is fine, it's just not getting a signal from the VTS housing. Make sure the two brown wires from the housing to the gauge are plugged in. If so, then it's time for a new VTS housing,

  3. #3
    levonhelmet's Avatar
    Join Date
    Dec 2006
    Location
    Toronto Ont Canada
    Posts
    196
    that is exactly how my VTS nightmare started. however it could be something else considering the speedo gauge doesnt work as well.but first the gauge went then it statred to blow the 7.5 fuse.but im putting my money on it being the VTS module starting to die....and it was a lot of money!

  4. #4
    oh dam i was hoping it would be something simple

  5. #5
    785xp's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Posts
    897
    +1
    7
    Chances are your speedo got moisture in it and is dead. If you have a friend with one, you could swap it out and try it.

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by marshro View Post
    oh dam i was hoping it would be something simple
    Just FYI...everyone thinks it is going to be simple. Some wish we could jump through the computer and fix it for them. They keep asking "what else? What else?" like they hope whatever we say next will be something they want to try...instead of the first recommendation.

    But really...how hard is it to take 5 minutes and trace two wires from your VTS housing?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. plz help urgent
    By 305coco in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 08-11-2007, 08:26 PM
  2. RXT OR RXP plz help me decide
    By RIVAFTW in forum 2-Stroke Performance
    Replies: 4
    Last Post: 08-08-2007, 12:44 PM
  3. New member plz help
    By blg1199 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-12-2007, 08:27 AM
  4. Riva Racing Stage 3 Issues!plz help
    By Seadooracer9 in forum 4-Tec Performance
    Replies: 19
    Last Post: 04-28-2007, 01:46 PM
  5. Someone plz help GPR or XLT guys
    By Redcrownline in forum Yamaha PWC Performance (2-stroke)
    Replies: 26
    Last Post: 02-20-2007, 04:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •