Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    2004 rxp rpm's?????????

    i was wondering i have riva intake grate power filter and thru hull exhuast also filled ride plate holes seeing about 6800 to 6900 on rpm is that right with my mods i think i need to change the prop if so which one?


  2. #2
    TERRY bigbuck12345's Avatar
    Join Date
    Aug 2007
    Location
    jacksonville fl
    Posts
    1,469
    Quote Originally Posted by soldierpage View Post
    i was wondering i have riva intake grate power filter and thru hull exhuast also filled ride plate holes seeing about 6800 to 6900 on rpm is that right with my mods i think i need to change the prop if so which one?
    YOU HAVE SOME BOOST LEAKS OR S/C CLUTCH SLIPPING YOU SHOULD BE AT 8100 RPMS OR YOU HAVE WAY TO MUCH PROP

  3. #3
    other than my mods its stock only got about 40hrs on it how would i know for sure also i havent really been able to test it on really smooth water been very choppy the last three times i have went out

  4. #4
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    pull the rubber intake pipe off that goes into the middle of the supercharger and put your finger in there (obviously not running) and if you can spin the s/c impelllor you got problems.

  5. #5
    I'm all out of favors!!
    Join Date
    Apr 2008
    Location
    Orlando
    Posts
    48
    Time for clutches.

  6. #6
    even a stock ski should do 7900 at worst and 8100 at best check to c if ur s/c fan will spin with ur finger with the engine stoped. u might have lost u s/c washers

  7. #7
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722
    Quote Originally Posted by soldierpage View Post
    i was wondering i have riva intake grate power filter and thru hull exhuast also filled ride plate holes seeing about 6800 to 6900 on rpm is that right with my mods i think i need to change the prop if so which one?
    You got some major problems there bro... Check that SC! NOW!

  8. #8
    wouldnt i see a pretty big performance loss if that were true this thing is still a beast it doesnt seem any less i am taking it out tommorrow i will get another reading on rpm and get back to ya

  9. #9
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    DO NOT take it out, if the clucthes are original they are probably slipping, and COULD shatter and you'd be screwed! 5 minutes to pop that SC hose off and feel it...

  10. #10
    ok took it out today got 7850 at peak rpm but keep in mind there was three foot swells wind was blowing 30 mph also i guess i should mention this i see where you guys are get 8000 rpm but i see where you say you weigh 140 well i weigh 250 would that be causing me to loose rpm?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 08-30-2010, 09:24 PM
  2. 2004 rxp lost rpms with stage 2 kit
    By hilltopbrent in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-25-2010, 07:43 PM
  3. 2004 RXP surging RPM
    By NJMatt50 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-21-2008, 05:06 PM
  4. 2004 rxp stock only 7600 rpms,63 mph
    By joe563 in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-01-2007, 12:46 PM
  5. HELP!! my 2004 rxp had low the RPM's at full throttle
    By rafyrxp in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 06-17-2006, 11:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •