Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    I'd kill myself on a crotch rocket so I got an RXP
    Join Date
    Oct 2006
    Location
    Arkansas
    Posts
    14

    Exclamation Engine/SC troubles...

    Hey all, took my stock 05 RXP (+intake grate) out for the first time this season last Saturday and had some problems. Started up great but noticed it sounded like the s/c was kicking on and off. Major power surges. Took it easy for awhile and never really got on it and then eventually it seemed back to normal. Ran WOT great and didn't have any problems til I shut it off for about 5 minutes and it did it again just for a few minutes when I fired it back up. The rest of the day it ran great. Any ideas/suggestions?? Thanks!


  2. #2
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    did you pull the sc'r and inspect it?...might have a little water leak if you have an external IC too? possibly old gas, since it's the beggining of the riding season? lots of possibilities.

    dunno for sure without more info.

  3. #3
    I'd kill myself on a crotch rocket so I got an RXP
    Join Date
    Oct 2006
    Location
    Arkansas
    Posts
    14
    I haven't pulled the s/c yet.....no external IC. It's bone stock except for the Riva intake grate. I am liking that bad gas idea tho! My friend's 05 RXP didn't have any problems tho, and I filled them at the same time and put the same amount of stabil in both towards the end of November.

  4. #4
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    You running Ceramic washers Clutch washers?

  5. #5
    I'd kill myself on a crotch rocket so I got an RXP
    Join Date
    Oct 2006
    Location
    Arkansas
    Posts
    14
    As of now, yes.....lemme guess....put the metal ones in? =)
    Could those have gone even though it ran great the rest of the day??

  6. #6
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Does'nt sound like they are gone yet. Does sound like they are slipping though. They will probably go soon. I would not ride it again until you get them replaced. If they go you are talking big $. I recomend you send it to Jerry for the metal washers as he has done tons of them.

  7. #7
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    Quote Originally Posted by speedskixp View Post
    Does'nt sound like they are gone yet. Does sound like they are slipping though. They will probably go soon. I would not ride it again until you get them replaced. If they go you are talking big $. I recomend you send it to Jerry for the metal washers as he has done tons of them.
    What he said.

  8. #8
    I'd kill myself on a crotch rocket so I got an RXP
    Join Date
    Oct 2006
    Location
    Arkansas
    Posts
    14
    Cool, thanks guys. Would a complete rebuild be out of the question? Replace it all, be done with it??

  9. #9
    daverxp4's Avatar
    Join Date
    Aug 2005
    Location
    montreal,canada
    Posts
    1,323
    Quote Originally Posted by Watdog View Post
    Cool, thanks guys. Would a complete rebuild be out of the question? Replace it all, be done with it??
    well the best thing is to open it first and inspect it,metal clutches as all you will need but if you got 100+hours on it hard riding an upgrade is always safer with the 2006 specs and be done with it for a good while.

  10. #10
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    Quote Originally Posted by Watdog View Post
    Cool, thanks guys. Would a complete rebuild be out of the question? Replace it all, be done with it??
    How many hours are on the SC?

    I would say if you got the money and above or close to 70 hours on the sc to shoot for a 08 rebuilt kit which has metal washers and call it a day. I dont know if the 08 rebuild kits are available yet though....

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 14
    Last Post: 08-02-2015, 02:10 PM
  2. 04 GTX SC troubles have me stumped
    By tel in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-27-2012, 11:02 AM
  3. engine compartment trouble
    By Lenn1562 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-06-2010, 03:41 PM
  4. Update: Engine/SC problems
    By Watdog in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-09-2008, 01:14 PM
  5. Race Engineering SC Drive Kits have arrived
    By Green Hulk in forum 4-Tec Performance
    Replies: 10
    Last Post: 01-03-2007, 05:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •