Results 1 to 5 of 5
  1. #1

    Boost at 7500rpms?

    What is the expectd boost of a Riva stage2 RXP running at 7500rpms? What is the max boost range for a stage2 at full rpms? I'm trying to find out if I have aboost leak. I can't get it up past 7700 so I'm using 7500rpms as a basis. Thanks!

    John


  2. #2
    Legend in my own mind Sirhc7897's Avatar
    Join Date
    Aug 2005
    Location
    Lake Butler, FL.
    Posts
    1,140
    When I was at 7800-7850 I want to say I was around 6 psi...

    At 8050 I am cranking just a hair under 8 and I believe at 8150 you are in the 8-8 1/2 range

    When I installed mine I had a boost leak and couldn't turn past 7600. Re-sealed it and removed the BOV and it went to 7850-7900. Had the prop repitched and it now sits comfortably at 8050 all day long in 95 degree heat...

    Edit - Knowing 5500+/- + 0psi and 8150 = 8+ psi I'm guessing you should be in the 5-6 range @ 7500-7700rpms?

  3. #3
    Quote Originally Posted by Sirhc7897
    When I was at 7800-7850 I want to say I was around 6 psi...

    At 8050 I am cranking just a hair under 8 and I believe at 8150 you are in the 8-8 1/2 range

    When I installed mine I had a boost leak and couldn't turn past 7600. Re-sealed it and removed the BOV and it went to 7850-7900. Had the prop repitched and it now sits comfortably at 8050 all day long in 95 degree heat...

    Edit - Knowing 5500+/- + 0psi and 8150 = 8+ psi I'm guessing you should be in the 5-6 range @ 7500-7700rpms?
    Chris, that sounds about right, same with the GTX here, at 8100 it`s at 8 psi...PR...

  4. #4
    Thanks for the info. So its 5-6psi's at 7500 rpms. I'll see what I'll get tomorrow. Hope my prolem is just as simple as a boost leak.

    John

  5. #5
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    JohnD - Check the hose connections, especially on the pipes going into the i/c. These tend to slip off when the motor torques, and may require double clamps. I now run double clamps on all pipe connections. Jerry and I both had this problem @ Mudbug.

    Also, make sure your old i/c blockoff plate is sealed with black permatex before the clamp is retightened. Peolple have complained about loosing boost from this part as well.

    Hope this helps.

    Brendan

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva B-1 Boost at higher RPM?
    By ecpChris in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 05-26-2011, 04:29 PM
  2. Boost at certian RPMs
    By Big brother in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 03-30-2011, 12:28 AM
  3. 250 Loosing Boost at WOT
    By Aquaholic6801 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 05-14-2009, 07:17 PM
  4. maxium boost at 8100 rpm
    By vduzin12 in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-09-2008, 03:24 PM
  5. Boost at 11.3
    By smc in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-03-2007, 02:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •